Excessive RAM usage MAC

Just for everyones information, I have a Mac Mini running Catalina with brief system specs of 2.3 GHz Quad-Core Intel Core i7 and 16 GB 1600 MHz DDR3.
Every time I export to Disk in PL4 the software just sucks up the RAM. If I try and export more than 5 photos at any one time it just crashes my Mac completely. This never happened in PL3, although the Process was quite a slow one when exporting to Disk. All I am doing is exporting jpegs at 99% from RAW processed Nikon Files.
Now I am no Computer expert here, but I have no other processes/software programmes running in the background and this still happens and its irritating in the extreme. I am temporarily using PL3 at the moment until hopefully some kind of Fix can be made.
Anybody seen similar, or have any ideas?


Does your Mac mini have any kind of graphics processor?

1 Like

Dear @Dinomite
welcome in the forum. The thread you atteched your post is in the Win section. Could you please start a new thread under Latest DxO PhotoLab/DxO PhotoLab Mac topics - DxO Forums and post it again

best regards


1 Like

Oops, I didn’t even notice that. Thanks Guenter. :grinning:

Moved here :wink:


Thanks @sgospodarenko !

1 Like

One of the main differences between PL3 and PL4 is that PL4 heavily uses good(supported) graphics processors for Deep Prime NR. It will work with CPU only but will be much slower and may use more RAM. If you do not have a supported graphics processor then you can still use PL4 but change to Prime NR rather than Deep Prime NR.

1 Like


Thanks for the information and coming back to me, much appreciated. Now knowing this, I should have just stuck with PL3 to be honest as this does pretty much everything I need apart from Deep Prime. Oh well, lesson learnt.

Why switch to PRIME from DeepPRIME, Mark? DeepPRIME can be configured to use the CPU.

Mark, The Processor I have in the mini is a Intel HD Graphics 4000 1536 MB.
I did not have this issue on PL3, nor in Capture 1 or Affinity. It exclusively occurs in PL4 only.

Thanks for moving the post. Apologies for putting it in the wrong section.

Hi Greg. I know, but for me at least Deep Prime is VERY slow on CPU only. Minutes as opposed to seconds whereas Prime is just less than a minute. YMMV.

I’m pretty sure that Intel integrated processors are not supported. My PC has the Intel processor in addition to Nvidia and the Intel processor isn’t even listed as a choice in preferences.

Just checked RAM hunger of DPL4 on my 2019 iMac (8core, 40GB RAM, Mojave)

PhotoLab increased RAM usage by 1 GB when Processing started, but never went up above that during the whole time. The XPCCor(n) processes took up to 6.5 GB at times, but always came back down again. Only one of the these processes went up, the other XPCCore(n) processes stayed below 100 MB (at a setting of “4”, see below)

All in all, there was nothing to worry about.

The Mini (assumed Late 2012) GPU shares memory with the CPU, but not more than 1GB according to what I find in MacTracker. Maybe you could run a few tests with different settings…

Reduce the number of simultaneous treatments. In your case, lower might be better anyway.

I’ve exported plenty of photos using DeepPRIME on my Mac mini (3 GHz 6-Core Intel Core i5, 16 GB 2667 MHz DDR4, Intel UHD Graphics 630 1536 MB) and it never crashed. I don’t run PL on that any more so cannot check what I had the maximum set to but I think it was 3 or 4 images and using the CPU. I also found it ran faster using the (paltry) GPU but would sometimes output corrupted images, so I stuck to CPU.

Hi Julian,

Do you mean you encounter problems when you queue-up more than 5 images in one scheduled Export-to-disk … or when you have this setting to > 5 (in Preferences) ? image

  • Given your problem, I suggest dropping this setting to 1 (simultaneously processed image).

Not a big deal, but … there’s little point in exporting to JPG at 99% … You’ll create smaller files (and, perhaps?, reduce processing load), without any discernible difference in image-quality, by dropping this to 95% (or even 90%).

Hope this helps … John M

Mark, Platypus and zkarj, many thanks for your generous input, I have reduced the processes as described to 4 and now rely on the PC CPU and so far have not managed to crash the mac mini, so all appears to be good for now.
Appreciate your input, Thank you.


Dear @StevenL

reading this thread I have noticed that the setting

doesn’t exist in windows version

best regards


Hi there,
Yes, it doesn’t exists because History on Windows isn’t kept between sessions yet.

1 Like

4 !!! - - I reckon that will be your problem … Try 2.

John M