Weird behavior of image browser

I noticed something strange

when the image browser is docked to the main window of PL, you can easily check or uncheck multiple items of the filter dropdown menu.

however, when the image browser is undocked, the behavior is different. the filter dropdown menu closes after each check/uncheck action. this can be very anoying, if you have to check/uncheck a lot of items.

maybe you guys can look into that issue

i think filter schemes could also be a great step forward

(PL3.1.0 4301 win10 64)

Hi Stephan,

Correct. I can reproduce this. However, I think that this is another incarnation of an input focus problem already discussed here : https://feedback.dxo.com/t/possible-regression-in-v2-2-ea-or-did-i-just-imagine-it/6091/9 .

Just try this :

  • After you have observed the problem, give the focus to another DPL window or even to a window of another application.
  • Then go back to the image browser window and try again.
  • Probably the filter menu will now behave as expected.

There’s a general problem in DPL with input focus management. It is not new and has multiple consequences. The image browser is the most affected UI element.

Anyway, it is rather strange that the image browser behaves differently depending on its docking state.

Hello,

Okay, I can reproduce the issue as well - it’s actual only when the Image browser is undocked and the selected image is affected by the Filter selection. I’ll create an issue on that.

Thank you,
Regards,
Svetlana G.

Hello guys,

The issue has been fixed and will be available with the next release.

Regards,
Svetlana G.

1 Like