Undesirable behaviour: PL4 trapping/blocking Function-keys

I use another application in tandem with PhotoLab; I invoke it (bringing it into focus) with a configurable “Hot key” … eg. F8 or Alt+F9, etc.

This worked fine until PL v4 - even when using a Hot-key that operates as a Shortcut in PL, such as F9.

With PL4, however, this no longer works; PL4 is trapping and blocking such keystrokes even when they are NOT valid PL Shortcuts; such as F6, F7, F8 … such that my tandem app is now inoperable.

Can this undesirable behaviour be corrected, please ?

John M

I hope that is the consequence of them preparing for proper keyboard shortcut support, perhaps as soon as 4.1.

@John-M, I have created nearly all my shortcuts for programs (under Windows, right?) with CTRL-ALT- or a combination with SHIFT.
If the programs are already started and minimized to the taskbar I recall them with WIN-, for example WIN-3.
Both works perfect here. PL4 doesn’t block that.

(Yes, Win 10).

By way of explanation: The “tandem app” I’m referring to is actually Irfan, which I use to grab screen-shots - often to illustrate a post to this forum !

I usually use a “qualifier” (such as Alt or Ctrl) too, Ralf … However, in cases where I’m trying to capture the options in a PL menu list, I cannot use, say, Alt+F8 because “Alt” causes the PL menu to close … so, prior to PL v4 I was able to simply use F8, which worked fine.

Unfortunately, PL4 is now trapping ALL keystrokes upfront - and “swallowing” any that it does not need for itself.

John