Photoshop 2019


(Cathy) #1

I am not able to install … Nik will not identify Photoshop as compatible host - have tried multiple times


(Alex) #2

Hi, Cathy.

Thanks for the information! Photoshop 2019 is not officially supported for now, but it will be very soon. In the meantime, you could use the previous version of Photoshop as a host application to avoid compatibility issues. Another option is to contact our support so that they better analyze and solve your specific issue.


#3

I just installed the new Photoshop and Lightroom and purchased the DxO Nik Collection fully expecting it to be compatible with the new programs, but apparently this isn’t the case. I fortunately did not delete the older programs which have the old Nik collection.

When do you expect the the new programs to be supported? It would be helpful for users if we had some time frame.


(Benoît) #4

Official compatibility should be there in November. But there’s a high chance that DxO support can already help you on that topic, as for now issues encountered have generally easy workarounds, so please contact it.


#5

Thanks, I’ll try to install and if that doesn’t work, I’ll contact support, or wait for the official notice.