Non Destructive Edits appears not to be working from PL4

Encounter the following situation on Mac mini M1 (2020), Big Sur 11.4:

  1. Export TIFF to Silver Efex Pro for conversion and edit.
  2. In Silver Efex Pro check that Non-Destructive Edits checkbox is checked.
  3. Select a preset and make edits.
  4. Click Apply and file is saved with change.
    (Up to this point all is well.)
  5. Look and the photo and see I want to make one more edit.
  6. Send the photo back to Silver Efex Pro by hit the Nik Collection button, changing the setting to “Export selected file without processing”, and click to send back to Silver Efex Pro.
  7. When the file appears in Silver Efex Pro it is set back to the default settings of Neutral and no edits from the previous editing in Silver Efex Pro are present. That’s the problem.

Edit: Tested more and see that some of the settings are being set correctly. However, the Filter Color, the Film Type, and the Toning settings are what I see as being the settings being set to the Neutral default settings. There may be others but I did not check every slider setting.

I have tried this multiple times and gotten the same results. Before I report this to Customer Support I wanted to see if anyone else had encountered this problem. Or, if this is a known problem that I missed hearing about let me know that also. Thanks.

Peace
Marvin

Have you verified the size of the files? File size is about twice the size of files that have been saved without the non-destructive setting.

Sending a colour image to Silver Efex and saving the result should make it possible to regain the colour image sent to SEP in the first place. I’ve never tried it though because of the gigantic file sizes of multipage 16 bit tiff files…

The file sizes I got this morning were when saving the file with the Non Destructive box checked was 233.7mb. and with the Non Destructive box not checked was 116.9.

Again the Filter Color, File Type, and Toning settings were not carried over with the Non Destructive box checked. So, there is consistently a loss of data. I’ll go ahead and file a report of the issue with Customer Support later today.

To be clear I am not trying to reverse the image to its color state. I am just expecting the Non Destructive copy to be opened a second time in Silver Efex Pro and see the settings I originally made and modify them. What I am seeing is that it not all settings are being retained.

Peace
Marvin

Maybe that is exactly what the checkbox is meant to provide. I’m not sure what the non-destructive stuff really does because I don’t use it (I always keep the original) - but here’s what DxO saying about it:
https://help-nikcollection4.dxo.com/non-destructive-workflow

Right. Those are the steps I am taking and the result is that not all the data is being maintained. I’ll put in a ticket later today.

Thanks.
Marvin

Hi Marvin,

It sounds like you’re using Nik Collection/Silver Efex Pro with PhotoLab - - in which case, there’s another way to be able to restart edits for an image in SEP … See here for details - It’s not an automated process, but I find it works well (for me).

John M

Appreciate the information John-M. I’ll get the problem logged to customer support. I’d like Silver Efex Pro 3 to do what it was advertised to do regarding saving selections.

Updated: Was not able to file with Customer Support. Encountering errors on the web site trying to switch back to my account to get information required of when I bought Nik Collection and how much I paid for it to complete a customer support ticket. I feel this is not the same quality company I have been dealing with since Optics Pro 8.

Peace
Marvin

Hope you can get that sorted out, Marvin. I’ve always found DxO to be genuine in their attempts to provide good support - - perhaps (technical) problems on their site is hindering that. I suggest you retry.

John