DXO PhotoLab 2.3.1 b43 export doesn't work

(Miroslav Perovic) #1

DXO PhotoLab 2.3.1 build 43 export doesn’t work on my macOS Catalina GM (10.15 - 19A582a).

(Günther Spitzer) #2

Hello Miroslav,

I´m a little surprised, OSX Catalina not yet available, or are you one of the “chosen” Beta-Tester

#3

I trust you notified the Dxo folks of the incompatibility. I guess this is why I wait to update the OS on my MBP.

1 Like
(Graxxor Anandro Vidhelssen) #4

It’s not just Catalina… I have 2.3.1 build43 and updated to 10.14.6 Supplementary Update 2 yesterday and now I can no longer export.

Doesn’t matter if it’s export to disk, application or Lightroom. Just sits there without spawning XPCCor1…2…3 etc.

I’m getting errors in my log.

DXOPhotoLab2 XPCCor : Connection did interrupt for com.dxo.XPCCor1
DXOPhotoLab2 *** dopcorDidEnd DOPCOR FAILURE

#5

Export worked fine last night - Catalina after the minor bugs update. Exported two photos to Original Folder, one in 0.2 secs and the other in 0.6 secs - although the cropped image took longer…

(LCDI) #6

Did you try on to the last update of PL 2 ?

(John Worsham) #7

I just tried exporting a CR2 file to Jpg on a Macbook Pro with Catalina with the update. It exported with no issue. It just did it.:blush: