Default settings put PC in sleep while rendering

Hey there,

I finally realized why my computer (Intel NUC) stopped after rendering (only 16 RAWs from a 240 RAW timelapse) overnight: Windows 10 put itself into sleep mode. I overcame this issue after two failed nights by setting “go to sleep” in Windows from 30min to never.

Still, movie programs don’t put the PC into sleep, I think neither does Youtube. DPL Render should by default not allow the PC to enter sleep mode. Just a quick suggestion from a new user :smile:

Thanks for the otherwise great software!

Hi there,
…and welcome to our community :wink:

Your point is interesting, maybe @sgospodarenko can tell us a bit more? S., the behaviour mentioned by our user, is something that we are aware of?

Steven.

Hello,

Yes, PL does not influence the PC settings and PC gets sleeping according to its settings.

Regards,
Svetlana G.

Hi,

I think that this suggestion should be considered. After launching very long jobs, DPL should not force the user to stay around in order to keep the PC alive.

Meanwhile, Attenbach could use little apps like Insomnia (https://dlaa.me/Insomnia/) or Dontsleep (https://www.softwareok.com/?seite=Microsoft/DontSleep). It’s easier to use than to have to tweak the Windows sleep settings when needed. With Insomnia, Windows will not go to sleep until you close the utility. DontSleep has a more practical time out setting.

2 Likes

Thanks for the tip! :wink:

Thank you all!

Ideally, instead of downloading third-party software, PL would incorporate the feature because it would be best for the PC to enter sleep mode as usual - after the job is done. Maybe next update? :wink:

1 Like

Hi @Attenbach,
I have personally took notice of your input: this is something that will be investigated.
Usually, a PC should go into sleep/standby mode only after idling for a while…
If the batch processes is still in progress, there is no idle time, therefore no sleeping/standby mode…
:thinking:

1 Like

This has to be checked. Idle usually means no user input. The CPU itself is never idle. So, one could think that a process making intensive I/0 operations should prevent Windows from going to sleep mode.
This doesn’t seem to be the case. For example, I have recently observed (Windows 10) that a download from the Web is not enough to prevent sleep mode from being activated.

3 Likes

…interesting. A download is in progress and it gets stopped by the Windows “Power & Sleep settings”…

This has happened to me too. So it is not just an isolated instance… As long as I remember to change the computer settings for sleep it is OK, but I agree, it should not be necessary.

Yes, sleep mode activates after a certain time has passed without Human input (mouse, Keyboard etc.)

It will NOT activate however when certain progresses are running, say a file transfer from a HDD or USB Stick.
I could start a 200GB copy and walk away, and 5 minutes after the copying has finished, the PC turns into sleep mode.
Same with movies - you can watch a 2 hour movie, once it’s over and there is no user input, the PC will fall asleep within 5 min.
So should DxO render… :slight_smile:

1 Like

More generally, sleep mode will not be triggered if one of the currently running processes (be it a Windows internal process or an application) says NO to the notification message broadcasted by the OS before going to sleep. So, if Windows does not go to sleep while watching a video, it’s not because it detects that a streaming operation is underway, it’s because the video player blocks the sleeping mode request (some do not, by the way).

Anyway, implementing this feature is a breeze. About a dozen lines of code.