Continue to support Mac OSX 10.14.6 for future versions of DXO PhotoLab!

I love DxO PhotoLab, but find the OS support too short. The renewal of OS at apple is too frequent (every year), also the support of “old” OS by DxO is too short. Other software development companies have understood this well (Topaz Labs, Serif, …) and offer very long support. Mojave is a 32- to 64-bit transition OS that has been the most stable for a long time and should not leave my machine for a few years. Professionals who have a reliable system are reluctant to change (something else to do than always run behind new things), so do like other companies, otherwise many will not follow you. I really like your software in addition it is French which is not so common in the industry. I would like to be able to support the development again, but not at the pace imposed by Apple, so if you do not do like the other companies who have understood this well, I could not continue, too bad for me but also for you.

Thank you.

5 Likes

I support this. Unfortunately I can not upgrade my imac to Big Sur but the computere works perfectly still. No need to buy a new one.

1 Like

This is the case for many people, we must slow down this race to replace machines, just so that multinationals make more money at the expense of nature and the user. So it is important that the software developers help with this. The very good Affinity suite for example supports Mac OSX 10.9 Mavericks → 11.0 Big Sur. They have understood everything, and it melts badly with Adobe, which does like Apple: programmed obsolescence. So I support these developers but boycott the others … DxO must take this path, if not more support …

3 Likes

Hello Christophe,
if you move your post to “What feature do you need” people can vote on it.

I agree with Christophe. Many of us are hobbyists or retired folks. We don’t have piles of cash, waiting to purchase the next new computer just so that we can keep our software running. We will look for alternatives that support our older computers and our cameras.
The rate of wasteful planned obsolescence continues to increase at ever alarming rates with shorter and shorter timeframes.

1 Like

Apple is in transition ; I wish to buy a new one ARM but they have not yet what I want.
The next version, at least, must be compatible !

I have transferred the subject as indicated by @Sigi.

Here : Longer Mac OS support! - #5 by m-photo

Thank you.

1 Like

Like everyone above, I strongly support this.

One more reason on top of the environmental and financial cost is that whenever a piece of software adds a new constraint, it becomes harder to find a solution. In the recent past, I have too often ended up in a situation where software A works only until version N of the OS and software B requires at least version N+1. Virtual machines can and do help but this is not what all uses want to (or even can) do.

Same situation here. I’ve even had to ‘downgrade’ my new 2020 Mac Mini from Catalina to Mojave or I’d have lost the possibility to use some essential audio hardware that can’t easily be replaced. This rat race of new hardware and system software only serves Apple, not us users.

I agree! I’ve been using DXO since. . . Geez, I can’t remember, but it was way before it turned into PhotoLab I was pretty excited when you announced a new module for PL, and was ready to jump right on, until I read that it will not run on my 2016 MacBook Pro. I PRAY that you guys will reconsider, and keep us that can’t afford to snag a brand new computer every few years. . .

1 Like

Vote here : Longer Mac OS support! - #5 by m-photo