BUG: PhotoLab will not start on 5K monitors


I’m a long time user of dxo (since version 4!). But since dxo Optics Pro 10 I cannot launch DxO on my 5K monitor. When I launch DXO I get the error “Direct X9 incorrectly installed”. However the bug has nothing to do with direct X9.
Changing my monitor resolution to 4K solves the issue.

I reported the problem to the dxo team in 2016 but the problem is still there: I tried dxo Optics Pro 11, DXO Photolab 1 and 2 and always the same problem.

I am documenting this here to help people running dxo on hi-res monitors: you will need to switch the resolution down while you run dxo. This bug does not seem to be documented anywhere when I google the problem.

1 Like

DPL 2 runs nicely on my 2019 iMac Retina 5K computer. The resolution does not seem to be the cause of your issues but an other link in the processing chain?

Thanks @platypus for documenting your experience here.
I’m running on Windows so perhaps this explains why it works on your end and not mine.

I´m running DXO PL 2 on a 5K screen… Never experienced the Direct X9 error so far.

Thanks @Philip_MUC : is this on Windows or MacOS?

I’m more curious to hear about your hardware and OS

Windows x??
What GPU?
What drivers is that running. Have you tried an earlier or later version?


What perhaps is special in my config is that I have 3 monitors connected: 5K, 4K and 2560px.
The problem is always fixed when I change the 5K monitor to 4K definition.

I’m using Windows 10 x64.
GPU: was using AMD Fury. Now I’m using Nvidia GTX 1080ti.

The exact error I get is:
“DXO Optics Pro was unable to start, this is usually because direct X9 is not properly installed…”

When I raised the ussue with DXO in 2016 they responded: “we have an incompatibility bug with 5K+ screens”