Where can I find the Fstoppers-Bundle - I purchase the Nik Collection 6.3?


All the explanations, including the link to fstoppers tutorial are in the mail you received from DXO. Please not that you have to create an account on fstoppers website for this to work : you will get an error at payment step if you don’t.

1 Like

No it doesn’t work! I purchased and have had no code at all

Good to know we need to create an account on FStoppers to make this work as well.

Some, or perhaps many, of us are still waiting for that email from DxO or whomever is supposed to be sending it. I have a ticket open, but haven’t heard anything since Friday afternoon.

1 Like

Happy news! I got my email today and was able to successfully redeem my coupon. :birthday: :champagne:

Hopefully, others have or will be getting theirs soon.

Good news – bugs fixed! Your Fstoppers tutorial is all yours

By this weekend as a user of Nik Collection 6 you should have received your personalized code to download the free tutorial from Fstoppers.
Please accept our apologies if you have experienced problems retrieving your free tutorial over the last few days! Due to a small bug on the Fstoppers website, some customers were unable to trigger the download. This has now been fixed.
If you were unable to redeem your coupon, please try again.
Sorry if you have been affected! Please don’t hesitate to get in touch with our support if you experience any further problems.
Ps: if you didn’t receive your codes make sure to receive informational messages as well as the latest on DxO’s offers, please sign up to our newsletter here or contact our customer service team
Warm regards,
The DxO Team

1 Like

Thanks to DXO for this nice offer and to Barbara for the great support. I thought that should be mentioned as well :wink:

I’ve bought 6.3 on August 31st, but have not received the code yet even though I have a) enabled the newsletter and b) checked the spam folder. I have contacted the customer service team on Sept 7th and have had a few exchanges through email since then. Nevertheless, the code is still missing.

Mileage can vary :exploding_head:

Hello Platypus,
I have also bought the 6.3 a few weeks ago. Did not receive the code either. Based on the comment from Barbara above I contacted support and within a day I had the code. I recommend you just follow up.

After a few mail exchanges with DxO Support, I got the code and directions on how to get the files.
Let me add a few comments.

  • DxO Support was friendly and did not waste my time in helping me, thanks for that, DxO
  • Directions: Getting the tutorials takes a few steps which are documented in a PDF that came with the code. The PDF showed all steps, but what looked like links to the respective pages were just blue, underlined texts.
  • Registering an account with fstoppers took a few iterations though. Captcha took a few tries before it actually produced the popup, Adding the tutorials and the coupon code went well…but the button that should have initiated the next step was greyed out. Repeated a few times, I finally was able to download the material. All is well now.

The tutorials are provided in different languages, which means that a few documents have been localised and the videos come with subtitles. I ended up getting the English material, without subtitles but easy to understand nevertheless. The video I just checked was well presented and structured.

All in all: Thanks, DxO, for providing what looks to be excellent material.

1 Like

apparently it is not fixed I just purchased the nik collection and when I fill in the coupon code with fstoppers it tells me: unable to redeem code. I double checked if I filled it in correctly please help?

update: it is now fixed, I received an email from fstoppers that is should work now and I could download the files!

So I tried to get hold of this course today. The code was sent to me, but when it was entered a message saying “coupon has been applied” pops up but the price doesn’t change. I tried it again and it says “Unable to Redeem Coupon”

I don’t know whose fault this is but it hasn’t been fixed in a couple of weeks and just leaves a bad taste.

I received my code for the free tutorial. I entered the code on fstoppers and received the message “Unable to Redeem Coupon”. I filled out a support ticket with DXO and received this message:


We are sorry you are having trouble using your coupon with FStoppers. Due to the fact that this error is originating on their website, you would have to contact FStoppers directly. We unfortunately have no way to troubleshoot anything that occurs on their website, our apologies.


Riley - DxO Labs Support Team

I sorry DXO uses the free tutorial as part of a package when you buy NiK Collections 6. You should be contacting fstoppers to figure out whats going on, not me. I a bit upset about this. I did fill out a support ticket with fstoppers but have not heard back yet.

Also in the same situation. Received the code yesterday following my purchase but “Redeem coupon not possible!” is displayed when I apply the code. The website will not allow me to move forward on the ordering process.

Hi all,
Emailed the DxO support yesterday and I received confirmation in the evening that all was fixed (Fstoppers issue apparently). Worked directly and I could access the videos. Very reactive DxO support team. If coupons go wrong again best thing is to email the support.