Viveza crashes Affinity Photo - Nik 3.3 on Big Sur

Nik 3.3 (25th Anniversary) installed on my MacBook running Big Sur, and works great from PhotoLab 4 and Affinity Photo, except for Viveza. It’s OK until you save your edit, then Affinity Photo crashes. This has only happened with Viveza, everything else I’ve tried has worked great.

Seeing the same thing here on my iMac.

I have the same problem with Viveza (Nik 3.3)

Same here. Anybody knows if there is a solution?

I have this problem also ~ is there anyone at NIK going to show & tell us how to cure the problem? It’s now a New Year & this problem has been going on since November 2020 ~ Please find a fix for it soon :pray:t3:

I have contacted the support of DxO. They are working to solve the problem. Please contact the support.

Just started to use Big Sur on Mac mini M1 and same thing happens. However, if you drop a tiff file directly onto the Viveza app then changes can be made and saved. It looks like it maybe a problem related to how Affinity Photo is receiving the file back rather than the way Viveza is handling the file save, Wanted to mention this in case it helps someone work around the current situation.

Edit: Just checked the Affinity Forums and they are aware of the problem.