Virtual Copy Confusion

I created a virtual copy of an image, so I ended up with two versions, identified as virtual copies 1 and 2. I later deleted virtual copy 2, but now I’m stuck with a single virtual copy (identified with a number 1 in a rounded square at bottom left of the thumbnail). How do I remove the virtual copy designation?

To be honest, I find PL’s implementation of virtual copies confusing. In Lightroom, I have a master image plus any virtual copies I create. In PL once I create a single virtual copy I no longer have a master image. I also don’t appear to have any way of renaming the virtual copies to indicate their purpose like I do in Lightroom. Why not just follow LR’s approach to virtual copies, which intuitively makes sense?


I’m a Windows user and that problem does not occur in my version. Perhaps its a Mac issue only and someone will chime in with whether this is a known issue or one specific to your setup.


The other day I ran into a similar problem - how was I to know which version was which? Here is what I did. After making the VCopy, I right clicked (cmd+left click) and found “rename on disk” in the contextual menu that pops out. Rename that file so you know what it is, and it will change in the library. No problem. Hope that helps. BTW…I have a similar problem with LR also, especially if I use more than one plug-in. I don’t remember the sequence my flow went, but that is another story and my personal problem. :slight_smile: Cheers!

Is it possible that accidentally you clicked on the red “Reject” icon of the copy #2 and now it is just hidden by the filter?

Try to reset the filters. Try to change to another folder and back. Try to restart the application.

I use PL1 on a Mac but haven’t seen this issue so far.

1 Like

Hi @drdu - - Actually, it’s quite simple …

When you create a “virtual copy” in PL it’s just another version of the image (of the same underlying file, to which different sets of corrections can-be / have-been applied).

Until you create the first virtual copy, the single image doesn’t have any identification number - Once you create the first virtual copy then all versions are assigned a unique number, starting with #1 (which is assigned to first version) - - BUT that does not mean that #1 is the “master” version … there is no such concept in PL … You can, in fact, safely delete the #1 version (if,say, you’re happier with one of the new virtual versions); when you do so the numbering system simply shuffles along.

Hope that helps …

John M


If I think not of copies of an image but of different recipes for customisation. The representation is just a thumbnail of how the (original, untouched) image looks likewhen the recipe is applied.

Nevertheless, it feels dumb to leave a number badge after all virtual copies are removed because it creates confusion rather than to avoid it.

1 Like

Thanks everyone for your responses, especially John M for your explanation of how PL handles virtual copies.

I realized that I was working in a collection, not in the folder with the image (I use Lightroom to manage my images, and only work in collections in PhotoLab), so when I removed the second virtual copy, it only removed it from the collection. I navigated in PhotoLab to the folder with the image and removed the second virtual copy there, and now PL doesn’t report the remaining version as a virtual copy anymore. Problem solved!

It would still be nice to be able to label virtual copies to identify their purpose, but now that I understand how they work in PL I can deal with it.

1 Like

That doesn’t happen in the Windows version. The vitual copy number disappears from the last remaining version of the image once all the virtual copies are deleted.


1 Like

Just to clarify, that’s what happens in the Mac version, too. After removing the second virtual copy from the folder, the number badge does disappear. My mistake was that I was deleting the second virtual copy from a collection, but it still remained in the folder, so the badge number remained on the first copy.

1 Like