Request: Crop to boundaries

Hi DxO,

One thing that frustrates me at times is having to manually adjust the crop after leveling the horizon.

It would be nice to have a button to adjust the crop to the image boundaries, eliminating black edges after leveling the horizon.

Kind regards, Frank

There is an “Auto based on keystoning / horizon” option in the Correction setting of the Crop palette. I have that set as my default. It does exactly what you are asking about. What version of PhotoLab are you using, Elite or Essential? It also works with the perspective tool if you have Viewpoint installed. I suppose it’s possible that it is an added feature of Viewpoint but I can’t be sure since I’ve never used PhotoLab without it. In any case, check to see whether you have that option available in the Crop palette.

Mark

3 Likes

My biggest resistance to use the auto crop is sometime’s it cuts of something i want to keep.
In manualcrop mode you see this object outside the clear window. And by adjusting crop ratio or adjusting perspective strenght you can preserve that object inside the clear window.

I would like a crop view which i can confirm by a enter or “ok”, this way i can check fast the cut out.
It’s a minor issue and i can in preset the cropmodule set to free ratio and off to activated in one click to preserve maximum image but seeing what’s outside the crop is better.

1 Like

Why not just keep the crop tool turned on in the viewer? You can have this and auto crop working at the same time and they will keep up with any perspective or horizon adjustments you make.

I usually prefer having the grid lines turned on while making horizon and perspective adjustments. Since grid lines aren’t visible with the crop tool enabled in the viewer, I will either let autocrop do its thing or - if I need to see what’s getting cropped out - wait until after making the adjustments and turning the grid lines off before performing auto-crop.

i do when i am manual correcting.


in this case 4:3 vs unconstrained is just a few pixels almost nothing.
(the grid of the crop does give me some guidens in straightening.)

What i would like to see is:
when i click horizontool: a grid when moving and clean when stable.
(it does show the crop wile activating horizontool whic his great:

when i click perspectivetools active it showes again the crop and lines:
.

So what i think i would like is the first time you select a image which is by preset activated touched by horizon or perspective it shows the “activated” tool window with horizon and next perspective
as a warning it cropped. or a button to click on if you want.
like this:


(i turn crop off and this is the image you get.)

It’s minor and as i said i can turn on Horizon and Perspective on 80% and have crop off
which give you this:


and then just activate crop done.
So it’s quite minor thing. if i like i can make in my preset a workaround (descibed above)
bigger is not having a auto appearinggrid when i manual adjust perspective and horizon.

and disapearing when i let the mousepointer go.(because then i knew it was 90% which i needed.)

So i have my preset setup as non active but set to my prevered starting points:
auto horizon, autobased on keystone in aspectedratio and 80% auto perspective (more naturallook)
So in two clicks i have my preview and three my crop. (if all goes well) And that’s why i want my grid active as soon as i move my mouse pointer on one of the sliderknobs of perspective or horizon (or move one) so i can check fast, now i need to toggle ctrl-G.
again minor issue but it can be improved… :slight_smile:

I’m really interested in your reply but I can’t Auto based on keystoning / horizon” anywhere in my Crop correction options. I have Elite and the latest updates. Any ideas why? Thanks, Mike 48%20pm

The wording is now just Auto. Simply change the drop down from Manual.

Thanks, @Joanna! I find Horizon doesn’t handle a lot of my stuff well, so I have a preset that excludes it. If I apply Horizon after a crop, the crop tool automatically sets to manual and I am left with what I thought @Frankster69 was referring to - black edges that need to be fixed up manually every time. I feel this is what should be taken care of automatically, exactly the same way as it is when applied before the crop, if the crop is set to auto.

That may be the case on a Mac, but on a Windows machine it still says “Auto based on keystoning / horizon”. Since I’ve always used PhotoLab with ViewPoint I don’t know if that setting is available in Elite when ViewPoint is not installed.

Mark

The crop tool goes to manual when you manually crop the photo then click “Close”. You may not notice this if you are using the crop tool that appears on the top tool-bar. If you then adjust the horizon either using auto or manual adjustment it will stay on manual until you click on the box that says “Manual”. If you click the manual box, a drop-down menu will appear that contains “Auto based on keystoning/horizon”. Simply click on this option and your problem will be solved.
Assuming that this is not an additional feature of Viewpoint as noted by mwsilver. If it is, I suggest that you consider purchasing Viewpoint. I find that it is a very useful addition to Photolab 3.

OK, first up, I’m truly grateful for the effort you have all gone to, especially @rrblint and @OXiDant, in responding. I have tried everything mentioned after ensuring I had the latest updates of PL3, VP and even FP but to no avail.
I think it must be to do with the Mac version, as I still get no further options offered that would fix the issue from within VP or in activated Crop tool in PL3. I won’t be switching to Windows, so it looks like I don’t have the solutions you advise.
Again, thanks! I hope to see it on the Mac version sometime…
41%20pm

If you now click where it says “Auto”, you’ll be all done. :slightly_smiling_face:

Unfortunately, not @rrblint. Clicking Auto (on Mac) just returns it to its full auto, pre-manual-crop state. I wish it weren’t so.

If you haven’t applied any horizon correction then auto mode will always try to crop to the full image, since it is trying to detect the nearest edges, which happen to be the full frame. Auto is there for those times when you have distorted the frame from being its normal rectangle.

Thanks, @Joanna! Yes, I’ve got that now although I do think that trimming the edges of a cropped image makes sense, as it appears to in the Windows version using “Auto based on keystoning/horizon”.