PureRAW Global Sharpening not working?

I first noticed this while working on @Andreas_S photo:

P3130743.RW2 (18.8 MB)

Posted On this thread

The OP was a notification of artifacts associated with oversharpening using PR2. I ran my version of PR2 on his file and observed no such artifacts. A few days later I ran his file through PL5 and DID observe the artifacts that Andreas had mentioned. I then exported the file with the same settings in PL5 as PR2(with the exception that Global Sharpness was reduced to -0.50 and compared it with the PR2 export with GS set to on(= +1.00 in PL5). The artifacts were clearly there in the PL5 export but not in the PR2 export. I then exported a version from PL5 with the Lens Sharpness module deactivated and the result was identical to the PR2 export with GS set to On. Here is a screenshot comparing 4 versions of the shot in FastStone IV 7.6 at 700%. Clockwise from upper left: Original RW2 file, PL5 output with GS set to -0.5, PR2 output with GS set to On, and PL5 output with LS deactivated.

Please note that the output from PL5 with GS= -0.5 is much sharper than the other three.

Okay, now about this time @Marie responded that the lens module used for this file is too aggressive and will be fixed in a future update. So Andreas’s problem will be solved. All is okay now, right? Nope.

Now my problem; I tried the same experiment on some of my files and found the same result on each: PL5 version is much sharper than the PR2 version. On my version of PR2 the result is the same as PL5 with Lens Sharpness deactivated. I can only conclude that, on my version of PR2 Global Sharpness is not working.

I am a Beta-tester for PR2, but never thought to compare the output of PR2 to that of PL5 with identical settings while we were in Beta. Maybe we all just missed it? However, I can clearly see the oversharpening on Andreas’ version processed in his copy of PR2, so apparently his copy is working properly. I have tried uninstalling PR2, redownloading, and reinstalling three times, all with the same result Global Sharpness is not working.

I don’t know what else to try.

Here are a couple more screenshot comparisons in the same order as before.

Does anyone have any insight on this issue? It’s really bugging me.