Problem with Module - No updates

#1

A few weeks ago I reported an issue with a Canon EF 28-135mm f/3.5-5.6 IS USM DXO lens module mounted on a Canon EOS R distorting the image. I did what they asked and downloaded info to thier specific site, but when I contacted the support team to ask them about progress a week later, I was told if I asked any additional questions it would put my ticket back at the bottom of the queue where it would have to start over. What? In other words don’t ask us what we’re doing to fix your problem or will make you start over from the beginning. Has anybody else experienced this with service? All I want it is for them to acknowledge that they see the issue.

I used to Love DXO and got a lot of people to adopt it on seeing the great results, but if that’s how they treat a customer when they have a problem, I seriously need to reconsider… Right now, DXO is useless unless I go in and manually fix the terrible distortion it is causing to my photos. That is my main lens and I don’t have any others to use. It takes my brand new $2000 camera and turns it into a pile of junk.

On top of that, there is no support for any of the EF-S lenses for that camera so I have 3 lenses that it useless on as well.

(Svetlana G.) #2

Hello @johncal,

I’m disappointed to hear that.

But maybe it’s just a technical issue and the system moves the tickets based on the update status. Anyway, could you, please, give me the ID of your support ticket and I’ll check the progress?

Regards,
Svetlana G.

#3

My support number is 190388. Just FYI, the lens I am having module lens correction problems with works fine in Lightroom. And they also have support for my Canon EF-S 10-28 lens and you guys don’t have any support at all for EF-S lenses with my EOS R camera.

I really wish you guys would fix this as it leaves my camera pretty useless unless I use Lightroom where everything works fine. I have been a loyal customer for years and think your product is clearly superior and especially love the “clear view” option. But none of this matters if it doesn’t work. I would hate to switch to Lightroom, but if you can’t address my needs then it doesn’t leave me with any choice.

Thank you for taking s personal interest in resolving my issue(s).

Best Regards,

John

(Svetlana G.) #4

Hello John,

So I was correct, it’s not their wish but the system workflow (as soon as you add new questions the ticket is updated and moved back). So now about your ticket in particular - right now it’s being investigated by the ImageData team. But I did the test with your image and can confirm - it’s definitely a bug which will be fixed after the investigation.

P.S. Please, do not worry, as soon as it’s fixed you will be notified.

Regards,
Svetlana G.

#5

I’m glad you saw the problem. Do you know how long it will take to fix the issue? Also, are they planning on supporting the EF-S lenses on this camera?

(Svetlana G.) #6

Well, it depends on the difficulty of the issue so I can’t tell you the time frames.
As for the lenses support, let’s ask @Marie about it.

Regards,
Svetlana G.

(Marie) #7

Hello,

Correction will be available at the end of the month.

Regards,
Marie

1 Like