Please support GPU acceration for RAW file editing!

photoloab-2
(Arne Ader) #1

I have used Dxo Optics/Photolab for several years. It’s my favourite raw editing program. However, it has significant disadvantage: Dxo Photolab is too slow for editing large (over 30 MP) RAW files. Please support GPU acceleration for RAW editing!

In my recent tests with Topaz Gigapixel 3.1 which is using both CPU and GPU acceleration came to light that GPU (Nvidia Geforce RTX 2070, 2304 CUDA cores) can be 40x faster than CPU (Intel Xeon 3,50 GHz, 4 Cores) if calculating the same picture!

(Alec Kinnear) #2

Topaz plugins are so slow (even with GPU processing that they desperately need hardware acceleration). But I agree - PhotoLab is very slow with my 5DS R files and it’s high time DxO adds GPU acceleration to PhotoLab.

The sliders are hopelessly slow unless one follows a very specific workflow (not enabling any lens correction or noise reduction until the very end).

1 Like
(PhilippeC) #3

DxO Optics Pro and DxO Photolab are both already supporting GPU acceleration; this was implemented years ago (at least by DxO Optics Pro 7 in 2012!).

This is achived using OpenCL: Check in the “Preferences” dialog and then in the “Performances” tab, that the OpenCL checkbox is activated. This is supported by both Intel & AMD processors (on the CPU side).

1 Like
#4

I do not have any OpenCL check box in either of my PL.
Did not have it in PL1.x and not in PL2.2.

I can set number of concurrent used cores/exports but that’s it.

On my MBP i7 dual core with Intel Iris 6100 I can set 4 parallel processes.
On my Mac mini i7 quad core I can set 8.

But never is the graphics card(s) ever used for anything other than zoom and pan.


#5

There are no options for GPU support in macOS.

This is stated by DxO support upon opening a support ticket:

The GPU option you are seeing in the program user guide is only for the Windows version of the program. If your video card and associated video hardware driver are compatible on your Mac for use in the program, GPU acceleration will be automatically turned on for you. Therefore, no GPU option is displayed in the Mac version of the program. There are a much wider variety of video cards available for PCs than Macs. This is why the option is available for Windows.

1 Like
(Alec Kinnear) #6

Thanks for the tip Required. The Mac side GPU acceleration is not particularly accelerated at this point. Like you I don’t see much use of the GPU when monitoring with iStat Menus. It looks like you are using Bresink but it’s the same thing.

Performance is much better on Sony A7 III 24 MB files than on the Canon 5DS R 50 MB files. Not twice as responsive but at least three or four times more responsive. Neither are real time though.

#7

I’m using apples own activity monitor to display the graphs. :slight_smile:

1 Like
(PhilippeC) #8

I forgot to mention that I am using the Windows version; is “OpenCl” also available on Mac?

#9

Unfortunately no.
The hardware graphics performance is quite poor on Mac.
A lot or most is done in CPU only.

1 Like
(PhilippeC) #10

Thank you for your response.
Is it so that the available graphical acceleration features are costly to implement (e.g.require some expensive licencing)?
Just as an example, I am also using the “Da Vinci Resolve” software for video editing, and this software fully support graphical acceleration on Mac (including with an external hardware connected by a high speed network).

#11

To my knowledge there are no license costs for OpenCL which is open nor Apples Metal/Metal2 and Chronos Vulcan which both are proprietary.

But I believe - as we have not had any real feedback from DxO on the matter - that they are actually working on it in some way.
I guess we will sit and wait for a while.

1 Like
#12

I’m running PhotoLab 2 Elite v2.2.2 build 23730 under Windows 10 64 bits 1809.

My processor is an Intel Core i5-8400 2800 MHz, with 16 Go DDR4 3200 MHz.

My GPU is Gigabyte GeForce RTX 2060 WINDFORCE OC 6G (rev. 2.0).

Unfortunately, when I attempt to activate the OpenCL checkbox in the “Performances” tab, I get this warning : *“Your graphic card seems to be slower than your CPU. Enabling OpenCL may decrease perforlance.”

And then I’m prevented from activating the OpenCL checkbox, and RAW processing performance remains of course very poor.

Is this situation normal? Do I need to get a better graphics card ?

Thanks a lot for any answer to this post.

2 Likes