PL5 - wrong TimeZone on export?

Hi,

I recognized that on my PL5 exports the timezone is set wrong (always set to 00:00 while it should be 02:00). PL4 handles this correctly.
When I check with exiftool the same raw file exported to jpg:

PL4:
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[Composite:Main:ID-Exif-SubSecDateTimeOriginal] SubSecDateTimeOriginal: 2021:09:07 11:15:50+02:00
[XMP-photoshop:Main:ID-DateCreated] DateCreated: 2021:09:07 11:15:50+02:00
[Composite:Main:ID-Exif-SubSecCreateDate] SubSecCreateDate: 2021:09:07 11:15:50+02:00

PL5:
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[IPTC:Main:ID-60] TimeCreated: 11:15:50+00:00
[Composite:Main:ID-Exif-SubSecDateTimeOriginal] SubSecDateTimeOriginal: 2021:09:07 11:15:50+00:00
[Composite:Main:ID-IPTC-DateTimeCreated] DateTimeCreated: 2021:09:07 11:15:50+00:00
[Composite:Main:ID-Exif-SubSecCreateDate] SubSecCreateDate: 2021:09:07 11:15:50+02:00

Could it be that PL5 has a bug with writing OffsetTimeOriginal?

Hello @abgestumpft ,

coul you provide us a file for test and tell me what you did in PL5 ?

Please, upload them on upload.dxo.com under your forum name (instead of the support ticket number) and let me know when ready.

Regards,
Marie

Hi Marie,

I just tried to create a small test case, but here it is working OK. So I need to check under which conditions this happens. I recognized this today when I had edited the same image with PL4 and PL5 and the capture time was 2h apart.

E.g. this also happened to the files where I compared the PL4 vs. PL5 DeepPrime export times:

With PL4 OK:

C:\Users\Sebastian\Desktop\0\PL4>exiftool.exe -G1:3:7 -S * |findstr -i "filename OffsetTimeOriginal"
[System:Main:ID-FileName] FileName: PA039627_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039628_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039633_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039637_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039639_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039641_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039649_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039650_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039653_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039658_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039659_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039661_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039664_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039670_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039671_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039681_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039686_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039688_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039690_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00
[System:Main:ID-FileName] FileName: PA039693_DXO_PL4.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +02:00

With PL5:

C:\Users\Sebastian\Desktop\0\PL5>exiftool.exe -G1:3:7 -S * |findstr -i "filename OffsetTimeOriginal"
[System:Main:ID-FileName] FileName: PA039627_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039628_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039633_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039637_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039639_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039641_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039649_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039650_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039653_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039658_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039659_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039661_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039664_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039670_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039671_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039681_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039686_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039688_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039690_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[System:Main:ID-FileName] FileName: PA039693_DXO_PL5.jpg
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00

Hi Marie,

now I was at least able to reproduce it a little bit. It looks a little different here, but at least for PL5 the OffsetTimeOriginal = +00:00. I have uploaded a ZIP file with the affected files.

When you:
right click P4040807.ORF → open with PL4 → export to jpg → looks ok (OffsetTimeOriginal not written at all)
right click P4040807.ORF → open with PL5 → export to jpg → OffsetTimeOriginal: +00:00

In contrast to my other attempts, no OffsetTimeOriginal is written this time with PL4 at all.
When checking the files with exiftool:

RAW File (I also checked and the camera has timezone +02:00 set)

C:\Users\Sebastian\Desktop\DXO_TimeZoneTest>exiftool.exe -G1:3:7 -S P4040807.ORF |findstr "02:00 00:00"
[System:Main:ID-FileModifyDate] FileModifyDate: 2021:10:27 20:51:49+02:00
[System:Main:ID-FileAccessDate] FileAccessDate: 2021:10:28 19:49:41+02:00
[System:Main:ID-FileCreateDate] FileCreateDate: 2021:10:28 19:28:09+02:00
[ExifIFD:Main:ID-36880] OffsetTime: +02:00
[Composite:Main:ID-Exif-SubSecModifyDate] SubSecModifyDate: 2021:10:27 20:51:49+02:00

PL4 File
As said above, here no OffsetTimeOriginal written (was written with +02:00 for my other files):

C:\Users\Sebastian\Desktop\DXO_TimeZoneTest>exiftool.exe -G1:3:7 -S P4040807_DXO_PL4.jpg |findstr "02:00 00:00"
[System:Main:ID-FileModifyDate] FileModifyDate: 2021:10:28 19:30:07+02:00
[System:Main:ID-FileAccessDate] FileAccessDate: 2021:10:28 19:55:55+02:00
[System:Main:ID-FileCreateDate] FileCreateDate: 2021:10:28 19:30:07+02:00
[ExifIFD:Main:ID-36880] OffsetTime: +02:00
[XMP-xmp:Main:ID-MetadataDate] MetadataDate: 2021:10:27 20:51:49+02:00
[XMP-xmpMM:Main:ID-HistoryWhen] HistoryWhen: 2017:05:09 10:00:11+02:00
[Composite:Main:ID-Exif-SubSecModifyDate] SubSecModifyDate: 2021:10:27 20:51:49+02:00

PL5 File:
with OffsetTimeOriginal: +00:00

C:\Users\Sebastian\Desktop\DXO_TimeZoneTest>exiftool.exe -G1:3:7 -S P4040807_DXO_PL5.jpg |findstr "02:00 00:00"
[System:Main:ID-FileModifyDate] FileModifyDate: 2021:10:28 19:28:57+02:00
[System:Main:ID-FileAccessDate] FileAccessDate: 2021:10:28 19:55:56+02:00
[System:Main:ID-FileCreateDate] FileCreateDate: 2021:10:28 19:28:57+02:00
[ExifIFD:Main:ID-36880] OffsetTime: +02:00
[ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[XMP-xmp:Main:ID-MetadataDate] MetadataDate: 2021:10:28 19:28:57+02:00
[XMP-xmpMM:Main:ID-HistoryWhen] HistoryWhen: 2017:05:09 10:00:11+02:00
[Composite:Main:ID-Exif-SubSecDateTimeOriginal] SubSecDateTimeOriginal: 2017:04:04 12:05:26+00:00
[Composite:Main:ID-Exif-SubSecModifyDate] SubSecModifyDate: 2021:10:28 19:28:57+02:00

Hello @abgestumpft ,

I’ve opened a bug to analyze it.
I’ll keep you up to date.

Thanks for data and information.

Regards,
Marie

@abgestumpft is not the only one seeing this problem; I am also, and it’s annoying.

For example, with a NEF image with Original Date/Time (XMP::photoshop\DateCreated\DateCreated\0) value of “2021:10:13 12:23:04.04-06:00”, the PL processed JPG image has a value of “2021:10:13 12:23:04.04-00:00”. The Digitized Date/Time tag (XMP::xmp\CreateDate\CreateDate\0) does not have this problem. PL 5 should not change the time zone for any of the date/time tags in output files. I don’t recall PL 4 doing this, so I assume it’s an inadvertent coding error.

ExifTool dumps of both images are attched.
PL DateTime issue JPG.txt (19.8 KB)
PL DateTime issue NEF.txt (18.1 KB)

An additional observation: the loss of time zone doesn’t appear to happen when I processed some smartphone jpg images (used PL 5 to some necessary perspective correction). So the bug may be limited to (some?) raw files.

Any updates on this?

PL 5.1.0 doesn’t fix the problem…

@Marie: It appears that 5.1.1 may have ‘sorta’ fixed this, but in an odd way.

Reprocessing images in folders where ‘original date/time’ had no time zone in the output file doesn’t seem to have changed (i.e., still '-00:00). Running a ‘Refresh’ on the folder makes no difference.

However, when I create a new folder in PL5 where no processing has occurred, the output JPG images now have a ‘original date/time’ time zone matching the original raw file.

It appears that PL5 has somehow cached the null time zone in previously created folders…

Can you confirm? Is there some way to over-ride the prior behavior?

With PL 5.1.2 this is still not working on my end:
Still OffsetTimeOriginal = +00:00 on all of my exports.

To clarify my prior note, I’m still seeing the problem with PL 5.1.2. Not sure what happened in the ‘sorta’ situation, but I again had the problem in a newly created folder.

I have a workaround using my DAM (IMatch) which can change the TZ information to the correct value, but having to do this for each image processed in PL is annoying.

Sebastian, I’ve looked at your image. I did the following:
exiftool.exe -*Date* P4040807.ORF
and I got:

File Modification Date/Time     : 2021:10:27 21:51:49+03:00
File Access Date/Time           : 2022:01:14 13:33:17+02:00
File Creation Date/Time         : 2022:01:14 13:31:43+02:00
Modify Date                     : 2021:10:27 20:51:49
Date/Time Original              : 2017:04:04 12:05:26
Create Date                     : 2017:04:04 12:05:26
Date Time UTC                   : 2017:04:04 10:05:26
GPS Date Stamp                  : 2021:10:27
Modify Date                     : 2021:10:27 20:51:49+02:00
GPS Date/Time                   : 2021:10:27 12:02:16Z

We never look at the file date/time, so the first three values are just ignored. But we look at Metadata tags and there, the only timezone we have in the source image is for Modify Date .
Maybe, we missed anything in the XMP?
This is what we have in the .XMP sidecar:

<exif:DateTimeOriginal>2017-04-04T12:05:26</exif:DateTimeOriginal>
<photoshop:DateCreated>2017-04-04T12:05:26</photoshop:DateCreated>
<xmp:CreateDate>2017-04-04T12:05:26</xmp:CreateDate>
<xmp:MetadataDate>2021-10-27T20:51:49+02:00</xmp:MetadataDate>
<xmp:ModifyDate>2021-10-27T20:51:49+02:00</xmp:ModifyDate>

HistoryWhen: which is also present with a timezone, is not read by our code.

So, again, the timezone is present only for ModifyDate. Unfortunately, we cannot invent the timezone and cannot guess what it is, based on the GPS or other references to the location.
Let’s think what we can do here.

Hi John, have you submitted any images to look at? I’ve answered to Sebastian already. The idea is that there is a fixed list of metadata tags we read and the tags in exported images are based on the source image data. So, if the timezone is missing in the source image, it cannot appear in the exported one. In the image provided by Sebastian, some tags had the timezone and some didn’t. And they got to the exported image exactly as they were in the source image.

Hi Arthur,

when I check the files:

exiftool.exe -G1:3:7 -S -*Time* P4040807.ORF
[ExifIFD:Main:ID-33434] ExposureTime: 1/4
[ExifIFD:Main:ID-36867] DateTimeOriginal: 2017:04:04 12:05:26
[ExifIFD:Main:ID-36880] OffsetTime: +02:00
[Olympus:Main:ID-2312] DateTimeUTC: 2017:04:04 10:05:26
[GPS:Main:ID-7] GPSTimeStamp: 12:02:16
[Composite:Main:ID-GPS-GPSDateTime] GPSDateTime: 2021:10:27 12:02:16Z

exiftool.exe -G1:3:7 -S -*Time* P4040807_DXO_PL4.jpg
[ExifIFD:Main:ID-33434] ExposureTime: 1/4
[ExifIFD:Main:ID-36867] DateTimeOriginal: 2017:04:04 12:05:26
[ExifIFD:Main:ID-36880] OffsetTime: +02:00
[Olympus:Main:ID-2312] DateTimeUTC: 2017:04:04 10:05:26
[GPS:Main:ID-7] GPSTimeStamp: 12:02:16
[Composite:Main:ID-GPS-GPSDateTime] GPSDateTime: 2021:10:27 12:02:16Z

exiftool.exe -G0:1:3:7 -S -*Time* P4040807_DXO_PL5.jpg
[EXIF:ExifIFD:Main:ID-33434] ExposureTime: 1/4
[EXIF:ExifIFD:Main:ID-36867] DateTimeOriginal: 2017:04:04 12:05:26
[EXIF:ExifIFD:Main:ID-36880] OffsetTime: +02:00
[EXIF:ExifIFD:Main:ID-36881] OffsetTimeOriginal: +00:00
[MakerNotes:Olympus:Main:ID-2312] DateTimeUTC: 2017:04:04 10:05:26
[EXIF:GPS:Main:ID-7] GPSTimeStamp: 12:02:16
[Composite:Main:ID-Exif-SubSecDateTimeOriginal] SubSecDateTimeOriginal: 2017:04:04 12:05:26+00:00
[Composite:Main:ID-GPS-GPSDateTime] GPSDateTime: 2021:10:27 12:02:16Z

Here you see that the .ORF does NOT contain the tag “Offset Time Original
It is also not present in the export I did with PL 4.

With PL 5 there is now “Offset Time Original”, and in my case this one is always on “+00:00”.
Exiftool also uses this tag to create the composite tag “Date/Time Original” (=[Composite:Main:ID-Exif-SubSecDateTimeOriginal] SubSecDateTimeOriginal)

When you check the exiftool docu https://exiftool.org/TagNames/EXIF.html, it says on those parameters:

0x9003 DateTimeOriginal string ExifIFD (date/time when original image was taken)
0x9010 OffsetTime string ExifIFD (time zone for ModifyDate)
0x9011 OffsetTimeOriginal string ExifIFD (time zone for DateTimeOriginal)
0x9291 SubSecTimeOriginal string ExifIFD (fractional seconds for DateTimeOriginal)

I think the cause is that Olympus does NOT store the exif-tag “OffsetTimeOriginal” in the .ORF file.
With PL4 the tag was not exported at all in this case. With PL5 it seems that (in case “OffsetTimeOriginal” tag is missing) this tag is then set with +00:00 on export.
I have now crossed checked with a Nikon Z6 II RAW file: here in the .NEF file the “OffsetTimeOriginal” tag is already set and also exported correctly both by PL4 and PL5.

Maybe the best is to behave like PL4 on export in the case “OffsetTimeOriginal” tag is missing: do not set this tag at all.

Sebastian,
in our code, whether the timezone tag is missing or we have it equal to 0, it is the same. So, when we read the tags and the timezone one is missing, we fill it in, with zeros. And upon saving, we cannot distinguish if it was missing or had zeros. So, it is important for timezone to be still missing after an export? Why? I need to understand this. Maybe, I missed something.

Hi Arthur,
in my opinion it is a mistake to fill unknown tags with zeros. As you say you cannot say afterwards anymore if the tag was missing or was really on zero before. On “Offset Time Original” this means PL5 will change the information from “Offset Time Original” missing = Timezone unknown to “Offset Time Original” = +00:00 → this Photo was taken in timezone +00:00

As said, with PL4 the “Offset Time Original” was not written in case it was missing. Now with PL5 it will be set to +00:00

One more thing: I also recognized that now the XMP-EXIF Tag DateTimeOriginal is set with that timezone “Offset Time Original” after export:

When checking first an Nikon Z6II NEF and then the Olympus ORF:

exiftool.exe -X -G1:3:7 -S * |findstr -i "System:FileName XMP-exif:DateTimeOriginal"
 System:FileName='DSC_0341.NEF'
 System:FileName='DSC_0341_DXO_PL4.jpg'
 System:FileName='DSC_0341_DXO_PL5.jpg'
 XMP-exif:DateTimeOriginal='2021:09:25 17:18:30.21+02:00'

 System:FileName='P4040807.ORF'
 System:FileName='P4040807_DXO_PL4.jpg'
 XMP-exif:DateTimeOriginal='2017:04:04 12:05:26'
 System:FileName='P4040807_DXO_PL5.jpg'
 XMP-exif:DateTimeOriginal='2017:04:04 12:05:26+00:00'

I think it’s also a mistake by Olympus not to set “Offset Time Original” (but seems like all the older cameras also didn’t set this). But in my opinion it’s also a mistake by PL5 to set the “Offset Time Original” = +00:00 in case it is missing.

1 Like

There is actually an exif tag for time zones. 0x882a “TimeZoneOffset” with 1 or 2 values:

  1. The time zone offset of DateTimeOriginal from GMT in hours,
  2. If present, the time zone offset of ModifyDate

The “OffsetTime…” tags are 0x9010/11/12 respectively.
Maybe we need to sort out which tag to use when?

Thank you for the response. Here’s a link to an original NEF and XMP showing the time zone set for -07:00 in XMP::\photoshop\DateCreated\DateCreated\0; the .dop file; and an output JPG showing the TZ for that tag is now set for -00:00. Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

PL5 should certainly populate intact all tags in the original file to the output file(s). If it’s only exporting an incomplete subset, that is a significant problem.

Let me know if you have questions or need more information.

There are a bunch of tags for times and time zone, with confusing and odd names. I believe (but would have to check to be sure) that in recent version EXIF gained the ability to include time zone information, although that’s something it didn’t used to have.

There are also XMP tags for date/times, which do include TZ information. I believe the most useful/important ones are
XMP::\photoshop\DateCreated\DateCreated\0 (for original date/time - i.e., the original image was taken) and
XMP::\xmp\CreateDate\CreateDate\0 (date/time when the image was digitized).

For most digital photo images, these have the same values, but they will be different for scanned images, etc.