PL5 Tag Field not read from .dop file

With default settings, PhotoLab automatically exports .dop sidecar files, which means that PL5 will write a) its version number and b) Rating instead of Rank. Sidecars not being backwards compatible between major versions makes PL4 ignorant of anything PL5 did. Nevertheless, PL4 should rewrite the sidecar with the rank value it has in its database.

If you work with PL4 and PL5 in parallel, it might be an idea to disable automatic settings export in order to return control of when a sidecar is written to you.

Chris (@Crispy) I tried to replicate your scenario on a Win 10 system with PL5.1.0.4690 using RW2(Lumix G9 RAW) one photo with a PL4.3.1 DOP, one with a PL5.0.1 DOP and a further photo with a PL5.0 DOP. All DOPs were original from my files but had to be modified in an editor to set the ‘Rank’/‘Rating’ fields. i.e. as ‘Rank’=3, ‘Rating’=1 and ‘Rating’=5 respectively. I then navigated to the directory in PL5.1.0.4690 and the snapshot is shown below.

This shows the correct star rating for the 4.3.1 DOP but the thumbnails for the two PL5.?.?.? are showing no rating at all!?

This was not what I was expecting. Remaining in the PhotoLibrary and quitting PL5 did not adjust the DOPs in any way, they remained as they were.



Entering the ‘Customize’ screen, “touching” each photo and exiting PL5 also left the DOPs intact.

I am not a novice at “hacking” DOPs but I am tired at the moment (the “excitement” of Christmas obviously or late nights writing posts to this forum (+age)!!) so I might have made an error at some point.

In previous tests where people have lost the ‘Tag’ (‘Red’, ‘Green’ or ‘Grey’) between PL4 and PL5 I used the same type of DOP “adjustments” and included the ‘Rank’/‘Rating’ for good measure and my tests exposed none of the issues others had encountered.

In this case I have not replicated (yet) your scenario but the ‘Rating’ set in the PL5.0 & PL5.0.1 DOPs should have shown up in PL5.1.0 I believe @sgospodarenko.

Edit:
I stated that I had not recreated your scenario but effectively I have in that 5.1.0 is not showing any rating, any change that makes a DOP update for one of the PL5.? photos will set the ‘Rating’=0. So I forced an ‘Export’ on the first of the PL5.? DOPs and the results are shown in the snapshots below .

I believe we have a bug @sgospodarenko!

Maybe I did not make it clear, but I am not using multiple version, I just upgraded to PL5 on both my computers and have a “certain” amount of pictures that was edited with previous versions, so I have multiple dop file versions.

So we are seing the same thing.

The other side of this scenario, which is my initial issue, is that when you edit the picture on one computer, on an external device, the star level set on this computer, and written with the value “Rating = n” in the dop file will be erased on the second computer, where the value “Rating = 0” will be overwritten in the dop file. (Which is quite fustrating when you spent some time to do the selection on the mobile computer).

Chris(@Crispy) you need to be careful when mixing edits between machines. Providing the directory has never been seen by the other machine then it should be possible to copy DOPs from one machine to the other and have them successfully and automatically (with the appropriate preferences set) imported on another machine.

Once the directory is known to a machine (i.e. the PL5 database on that machine) any changes that occur to a DOP that change this Uuid (which is any made by PL5 on another machine)

will result in the image being imported as a a Virtual Copy, i.e. the above Uuid must correspond to the Uuid in the database otherwise PL5 will protect the database entry and the DOP by adding the DOP details as a Virtual Copy. If there is no entry in the database then the DOP will effectively become that new DB entry providing the ‘Load settings automatically’ preference setting (at least) is set. If the automatic load option is not set then the DOP will always create a Virtual Copy when/if it is imported.

That brings us to your “issue” which I cannot exactly copy because the test copy of PL5 on my test machine has lapsed and I need to make a decision as to whether I am prepared to use a PL5 licence from my pool on that machine!? The best I can do is to try to emulate the issue on my main machine.

  1. Test 01:- I changed the DOP ‘Rating’ from 4 to 2 externally with PL5 down, restarted PL5 and it did not acknowledge the change automatically neither did it change the DOP.

  2. Test 02:- I changed the DOP for 2 to 5 externally with PL5 running and it did not acknowledge the change to 5 but did change the DOP back to 4 in the next DOP update cycle.

  3. Test 03:- I recreated the original directory afresh but added a 5.1.0.4690 edited photo which came in as the second photo. None of the ‘Ratings’ from the PL5.? DOPs were imported!?

  4. Test 04:- I set the ‘Ratings’ for the Test 03 photos to 2, 3 & 4 stars in PL5 and forced PL5.1.0.4690 to export all the DOPs. These photos and DOPs were then copied to a new directory and PL5 opened that new directory and none of the photos had any ‘Ratings’ showing. Importing the DOP sidecars did not change the situation but perhaps that was because PL5 had done a DOP update in the meantime and set all to 0!!

@sgospodarenko it appears that the latest version of PL5 won’t import ratings made by it (any PL5 release) and then one way or another overwrites the DOP with respect to ‘Ratings’ in line with it not recognising the values in the first place, i.e. ‘Ratings’-0!!

I don’t know if this is related, but be aware that Nikon (and perhaps others) store a default XMP Rating of ‘0’ in the raw file. Depending on the software you’re using, this could overwrite whatever Ratings you add in the software.

One more instance of manufacturers doing what they want in an environment where there aren’t enforceable standards…

@jch2103 Thank you for adding an additional level of complexity to the situation, sorry sarcasm is not allowed. Hope you are keeping well.

Once we can get PL5 to behave with its own ‘Ratings’ settings we should test scenarios that you identified alongside other software e.g. Fast Raw Viewer(FRV) setting ‘Ratings’ and recognising ‘Ratings’ set by PL5 or not as the case may be.

In fact while writing this I used FRV to set ‘Ratings’ for 3 RAW photos and, with metadata sync set, PL5 picked them up instantly! Changing one to 5 shows up in the DOP and the ‘xmp’ sidecar but FRV still sees it as 3! Getting FRV to copy the file to a subfolder it appears to have a 5 rating (need to check if there is a refresh function in FRV and if not make a request to the author).

Take care

I have the exact same problem…

I retried this protocol with the new PL 5.1.1, but with the same result.

Haha, I also hoped that this problem was fixed when I saw PL 5.1.1 Version popping up. Really hope this annoying bug fill be fixed soon…

Good morning guys,

As this is not a bug (the algorithm will soon be explained in FAQ) and the change of the behavior will take some time - we should find a good solution and not to mess up everything you’ll have to wait a bit.

Regards,
Svetlana G.

Hello Svetlana,

thanks for the head up.

However, do you mean that having rating content from dop file, and only for v5 dop version, ignored and reset is intended ?

1 Like

Hello!

  • Well the algorithm of the prioritization of the files containing this data has been changed with the introduction on xmp support (it also depends if it’s a master image or VC). Everything will be explained in details in FAQ very soon.

Regards,
Svetlana G.

@Lars, @Crispy and @sgospodarenko please see my post at Lost all ratings in PhotoLab Elite 5.1.0 ??? - #16 by BHAYT if you are looking for a long read!?

Hi Svetlana, any news on the FAQ ?

In addition, considering my use case scenario (using a laptop to make first edit and rating when on the go), how can I make it work again like I used to do using PL4 ?

Good morning!

@Musashi could you, please tell if it’s already published?

Thank you
Regards,
svetlana G.

Hi @sgospodarenko , @Crispy ,
The content has been produced and localized, our support team has received and should work on adding it to the website.
As for now here are some explanations

Best regards

1 Like

Hello Musashi,
if I use exclusively Photo Supreme as my DAM(and xmp files) and do not do any metadata editing within DPL should I turn on off “synchronization”. Up to now my understanding is to turn it off.

Best

Sigi

The table is very helpful, @Musashi .

…but it also means that .dop sidecars don’t work as database backups, which is a pity…

Note: Should you mention “Advanved History” in this table?

As far as I can see best off, I use PS as well and will keep my strong off.