PL5 Tag Field not read from .dop file


sorry for taking so long to post. I had been qite busy. And thanks for the time spend to try to reproduce my problems!

To sum thing up again:

  • Reading .dop/PL4 files works fine.

  • Reading .dop/PL5 files does not show the ProcessingStatus, even if “ProcessingStatus = 1” is set in the .dop file. This information is only read from the database if present.

With PL5 running thing get interesting:

  • Copping a picture with .dop/PL5 file within PL to a new folder, ignores the ProcessingStatus field and show it in the same status as in the source folder.

  • Copping a picture with .dop/PL5 file within the Windows Explorer to a new folder while PL5 is running and pointing to the target folder, creates a virtual copy of the picture. The for the original picture ProcessingStatus is ignored. but for the virtual copy ProcessingStatus is shown correctly.

There must be something messed up. And that is with reading the ProcessingStatus filed an that virtual copys are created when copping files.

Regards, Lars

ps: 1. Picture: Copy within PL5; 2. Picture - Copy with windows explorer

2021-07-22 T130343 (moto x4).jpg.dop (8,6 KB)
2021-07-23 T184842 (moto x4).jpg.dop (17,0 KB)

Dear Lars,

  • It means that your image was never processed but not the tag status.
    And for the tag status I see “ShouldProcess = 2,” which is equal to ‘undefined’ for the first image and Master of the second and ShouldProcess = 0, which means ‘green/pick’.

So this is exactly what we can see in your screenshot.

Svetlana G.

Hi Swetlana,

Ok thanks for correcting me. It seeams ShouldProcess is changed by PL5 when opening a file not in the database.

I will upload the above .dop before and after PL5 touched them and not recognicing the files (empty database and cache).

2021-07-22 T130343 (moto x4).jpg.dop (8,6 KB)
2021-07-23 T184842 (moto x4).jpg.dop (8,6 KB)

“ShouldProcess" is changed from “0” to “2” when the file is touched and not present in the database (or cache).

2021-07-22 T130343 (moto x4).jpg.dop (8,6 KB)
2021-07-23 T184842 (moto x4).jpg.dop (8,6 KB)

Is there any additional information I can provide?

Thank you. Nothing for now. We’ll do the first investigation.

Svetlana G.

With PL 4 and 5 on Mac, I find the following behaviour:

When I set PL 4 and 5 to NOT import and export settings automatically, the Pick/Reject lamps turn on and off as expected when I tell PL4 to export and PL5 to import settings (using the file menu).

When I set either PL to import and export settings automatically, the Pick/Reject lamps DO NOT change as expected, even if I tell PL5 to import settings (using the file menu).

This looks like PL4 is NOT updating the Pick/Reject entry in the sidecar, even if set to do so automatically.

1 Like

Hi all,

It seems that recently, when editing the number of stars of an image on a second computer, on an external drive, this rating is ignored on a second computer when reading the dop file. The other settings related to the image itself are properlly imported.

I believe this was not the case in PL4, but I cannot try that anymore. Is this a known limitation or a new issue ?


Can you check for behaviour similar to this:

Ok, there is definitly something strange.

I made a new folder with copy of two pictures: one with a PL4 dop file, one with a PL5 dop file. The number of star is directly seen for the PL4 dop file, but not from the PL5 dop file.

PL4 dop file initially contains:

Sidecar = { [...]
Software = "DxO PhotoLab 4.3.1", [...]
Rank = 3,

PL5 dop file initially contains:

Sidecar = { [...]
Software = "DxO PhotoLab 5.0.2", [...]
Rating = 1,

Once the folder is loaded within PL5, the content of the files are modified as:
PL4 dop file is transformed to:

Sidecar = { [...]
Software = "DxO PhotoLab 5.1", [...]
Rating = 3,

PL5 dop file is transformed to:

Sidecar = { [...]
Software = "DxO PhotoLab 5.1", [...]
Rating = 0,

Of course I tried to modify the PL5 dop changing “Rating = 1” to “Rank = 1”, but with no result.
dop file sync is activated in both direction.
XMP sync or not do not change the behavior.

With default settings, PhotoLab automatically exports .dop sidecar files, which means that PL5 will write a) its version number and b) Rating instead of Rank. Sidecars not being backwards compatible between major versions makes PL4 ignorant of anything PL5 did. Nevertheless, PL4 should rewrite the sidecar with the rank value it has in its database.

If you work with PL4 and PL5 in parallel, it might be an idea to disable automatic settings export in order to return control of when a sidecar is written to you.

Chris (@Crispy) I tried to replicate your scenario on a Win 10 system with PL5.1.0.4690 using RW2(Lumix G9 RAW) one photo with a PL4.3.1 DOP, one with a PL5.0.1 DOP and a further photo with a PL5.0 DOP. All DOPs were original from my files but had to be modified in an editor to set the ‘Rank’/‘Rating’ fields. i.e. as ‘Rank’=3, ‘Rating’=1 and ‘Rating’=5 respectively. I then navigated to the directory in PL5.1.0.4690 and the snapshot is shown below.

This shows the correct star rating for the 4.3.1 DOP but the thumbnails for the two PL5.?.?.? are showing no rating at all!?

This was not what I was expecting. Remaining in the PhotoLibrary and quitting PL5 did not adjust the DOPs in any way, they remained as they were.

Entering the ‘Customize’ screen, “touching” each photo and exiting PL5 also left the DOPs intact.

I am not a novice at “hacking” DOPs but I am tired at the moment (the “excitement” of Christmas obviously or late nights writing posts to this forum (+age)!!) so I might have made an error at some point.

In previous tests where people have lost the ‘Tag’ (‘Red’, ‘Green’ or ‘Grey’) between PL4 and PL5 I used the same type of DOP “adjustments” and included the ‘Rank’/‘Rating’ for good measure and my tests exposed none of the issues others had encountered.

In this case I have not replicated (yet) your scenario but the ‘Rating’ set in the PL5.0 & PL5.0.1 DOPs should have shown up in PL5.1.0 I believe @sgospodarenko.

I stated that I had not recreated your scenario but effectively I have in that 5.1.0 is not showing any rating, any change that makes a DOP update for one of the PL5.? photos will set the ‘Rating’=0. So I forced an ‘Export’ on the first of the PL5.? DOPs and the results are shown in the snapshots below .

I believe we have a bug @sgospodarenko!

Maybe I did not make it clear, but I am not using multiple version, I just upgraded to PL5 on both my computers and have a “certain” amount of pictures that was edited with previous versions, so I have multiple dop file versions.

So we are seing the same thing.

The other side of this scenario, which is my initial issue, is that when you edit the picture on one computer, on an external device, the star level set on this computer, and written with the value “Rating = n” in the dop file will be erased on the second computer, where the value “Rating = 0” will be overwritten in the dop file. (Which is quite fustrating when you spent some time to do the selection on the mobile computer).

Chris(@Crispy) you need to be careful when mixing edits between machines. Providing the directory has never been seen by the other machine then it should be possible to copy DOPs from one machine to the other and have them successfully and automatically (with the appropriate preferences set) imported on another machine.

Once the directory is known to a machine (i.e. the PL5 database on that machine) any changes that occur to a DOP that change this Uuid (which is any made by PL5 on another machine)

will result in the image being imported as a a Virtual Copy, i.e. the above Uuid must correspond to the Uuid in the database otherwise PL5 will protect the database entry and the DOP by adding the DOP details as a Virtual Copy. If there is no entry in the database then the DOP will effectively become that new DB entry providing the ‘Load settings automatically’ preference setting (at least) is set. If the automatic load option is not set then the DOP will always create a Virtual Copy when/if it is imported.

That brings us to your “issue” which I cannot exactly copy because the test copy of PL5 on my test machine has lapsed and I need to make a decision as to whether I am prepared to use a PL5 licence from my pool on that machine!? The best I can do is to try to emulate the issue on my main machine.

  1. Test 01:- I changed the DOP ‘Rating’ from 4 to 2 externally with PL5 down, restarted PL5 and it did not acknowledge the change automatically neither did it change the DOP.

  2. Test 02:- I changed the DOP for 2 to 5 externally with PL5 running and it did not acknowledge the change to 5 but did change the DOP back to 4 in the next DOP update cycle.

  3. Test 03:- I recreated the original directory afresh but added a edited photo which came in as the second photo. None of the ‘Ratings’ from the PL5.? DOPs were imported!?

  4. Test 04:- I set the ‘Ratings’ for the Test 03 photos to 2, 3 & 4 stars in PL5 and forced PL5.1.0.4690 to export all the DOPs. These photos and DOPs were then copied to a new directory and PL5 opened that new directory and none of the photos had any ‘Ratings’ showing. Importing the DOP sidecars did not change the situation but perhaps that was because PL5 had done a DOP update in the meantime and set all to 0!!

@sgospodarenko it appears that the latest version of PL5 won’t import ratings made by it (any PL5 release) and then one way or another overwrites the DOP with respect to ‘Ratings’ in line with it not recognising the values in the first place, i.e. ‘Ratings’-0!!

I don’t know if this is related, but be aware that Nikon (and perhaps others) store a default XMP Rating of ‘0’ in the raw file. Depending on the software you’re using, this could overwrite whatever Ratings you add in the software.

One more instance of manufacturers doing what they want in an environment where there aren’t enforceable standards…

@jch2103 Thank you for adding an additional level of complexity to the situation, sorry sarcasm is not allowed. Hope you are keeping well.

Once we can get PL5 to behave with its own ‘Ratings’ settings we should test scenarios that you identified alongside other software e.g. Fast Raw Viewer(FRV) setting ‘Ratings’ and recognising ‘Ratings’ set by PL5 or not as the case may be.

In fact while writing this I used FRV to set ‘Ratings’ for 3 RAW photos and, with metadata sync set, PL5 picked them up instantly! Changing one to 5 shows up in the DOP and the ‘xmp’ sidecar but FRV still sees it as 3! Getting FRV to copy the file to a subfolder it appears to have a 5 rating (need to check if there is a refresh function in FRV and if not make a request to the author).

Take care

I have the exact same problem…

I retried this protocol with the new PL 5.1.1, but with the same result.

Haha, I also hoped that this problem was fixed when I saw PL 5.1.1 Version popping up. Really hope this annoying bug fill be fixed soon…

Good morning guys,

As this is not a bug (the algorithm will soon be explained in FAQ) and the change of the behavior will take some time - we should find a good solution and not to mess up everything you’ll have to wait a bit.

Svetlana G.