PL3.0.3: Pipette for white balance does not work

Today I have updatet from PL3 v3.0.2 to v3.0.3 build 4295 (Windows version).
The pipette for the white balance does not do anything. I can click wherever, but nothing changes.
W10x64, PL3.0.3 4295

Same Build here, but the pipette works fine.

Ralf, ich habe die gleiche Version mit Win 10x64. Die Pipette funktioniert bei mir wie gewohnt.

All I can suggest is downloading the update again; it might have been a bad download. Mine works without a problem.

Hello @Ralf_Brinkmann,

I have no issue with WB pipette as well. Could you, please, try to reinstall the build and try on several images?

Waiting for your results.

Regards,
Svetlana G.

Ok. I could not imagine, that the download was broken, because the normal editing worked.
But there were some more mistakes, I noticed:
The pipette did not work,
pressing the “M” key on a selected area in the local corrections did not show the mask
and … oh, I forgot.

I closed the program and relaunched it again this morning.
Now all these things worked! :smiley::smiling_face_with_three_hearts:

There is only one more thing left through all versions since PL2.x:

Sometimes I can not edit the filename (F2). I already wrote about this problem and is has not changed.
I can edit the filename for example for the first 14 files, then from 15 to 20 it does not work, the I can do it again with the next files, maybe at 37 or 54 it stops again and I have to do it external (IrfanView is very good to change the image name and the dop file at the same time).

I did not find any rule for it and it has nothing to do with the amount of files. It happens with 80 files as well as with 600.

I hope you find this bug one day. Perhaps you have to use a Windows computer for it.

1 Like

I’ve had PL3 features and commands stop working, too. Restarting restores everything. Don’t know why, but the problems have mostly subsided for me. Could be driver and Windows updates, or maybe it is a hard-to-reproduce bug in PL3. My support request got closed.

Yes, very strange. It’s the first time that I had such a problem.

I’ve found a way to reproduce the problem consistently - sort of. Using a TIFF file generated by Color Efex Pro, I can get PhotoLab 3.0.3 into a crashing loop: I make any adjustment at all, and within a minute or two everything in PhotoLab flashes a lot, then the adjustment I was last working on turns off. In the midst of all this, the RGB white balance picker stops working entirely, but other adjustments I’ve tried so far don’t stop working. So I’m going to hazard a guess that the flickering and resetting I’m seeing is the new white balance panel dying over and over. And I can’t make it stop. Support Ticket #202000.

Hello guys,

@Egregius thank you for the info. We’ll investigate the scenario.
Just one question, are you also running the update 1909?

Regards,
Svetlana G.

Thanks, Svetlana! Yes, I am running that update.

Okay, thank you. So it looks like exactly this is the reason of PL3 malfunctioning. We’ll investigate.

Once again, thank you for the quick reply.

Regards,
Svetlana G.