PhotoLab Mac Users : Status on Catalina (formerly Don’t upgrade to CATALINA topic)

Dear Mac PhotoLab Users,

As you may have heard, the new version of Mac OS X (10.15 - Catalina) has been released.

We strongly recommand that you do not upgrade to this version as PhotoLab 2 is not compatible.
The teams are fully focused on fixing this issue and will release an update as soon as possible.

We’ll keep you informed.

Thanks for your comprehension
The DxO Team

------ October 16th 2019 - Update ----------

The fix available for PhotoLab 2 users is already available.
You should have been warned to update your version to 2.3.2 on startup.
Please do this update before installing Catalina and you won’t have any issues.

For those of you who have already upgraded their macOS, a fix will be available anytime soon to fix eventual ghost images, or database issues in finding images.

------ October 31th 2019 - Update ----------

Fix has now been released for PhotoLab 3 as well (version 3.0.1)

Topic changed title as we constantly keep you informed of our work regarding Catalina and PhotoLab.

Thanks for your comprehension.
The DxO Team.

So does the 2.3.2 update correct this?
Just curious as I am not using Catalina.

Yes @Tom

The 2.3.2 update fix things in order to prevent issues for people who hadn’t upgraded to Catalina yet (whic is your case)

The team is still working on the full fix, to resolve the issue for all users who had migrated already, and we’ll inform you as soon as we can on when it will be available.

Thanks for your comprehension.

The DxO Team

1 Like