Photolab 6 elite access errors

Hi, it seems every time I try to access something from within the program I get an access error message 403 server error access forbidden.
I am running Dx0 photolab 6 elite on a win 10pro 64bit machine.
Anyone else getting this problem ? any ideas? I have submitted a support request .


Hi Keith and welcome,

Not sure what you mean by “access something”. Do you mean exporting to another application or to some online site?

Or a network disc
Or a protected folder
Or …

Do you have antivirus/malware security software running? It might be interfering with something PL is trying to do. However, the 403 error suggests that DxO’s web server accessed by PhotoLab is refusing requests due to a permission problem. It might be something DxO has to fix on their end.

I should have said " access optics modules or software updates" I cant even do it directly from the Dx0 website anymore. When I first downloaded the software it worked (ver 6.0) but after updating to ver 6.1 no joy when trying upgrade to ver 6.1.1

I dont have any download manager or work through a proxy. I have seen this problem before when a website uses geo blocking (block certain browsers from certain locations)

This is a possibility. Please open a support ticket at the experts there will help you.

It was caused by a download manager i use, the guys at Dx0 solved my problem (unblocked my IP ), so now everything works and I have put an exception into the download manager so it does not cause me any problems going forward.