Photolab 2 uses a lot of memory and hangs frequently


#21

Hi, Photolab2 just hangs for a rather long time when I launch it (the dreaded beachball!). II just sent a diagnostic report to support.
The app is inusable for me at the moment.


(David Page) #22

Hi Chris,

I’m just downloading some updates for Mojave, I’m currently on 10.14.2. Not holding much hope that this will cure my problem as I can use all my other editing/viewing apps to access my USB located files with no problem but you never know… I’ll update this thread with anything I find out.


#23

I’m on 10.14.3, no difference…


(David Page) #24

Yep, finished upgrading to 10.14.3 and no difference.


#25

I upgraded to the latest version of PL2 and ran into the exact same problem others are reporting on this thread. Up until the upgrade I did not have this problem, and after it I did. Perhaps that is coincidental, perhaps not, but I found myself hung for 10 minutes and more when opening a folder with about 70 imagers in it.

I tried to fix the issue by removing the entire PL2 configuration/database folder and restarting PL2. That did not work so I created a new image folder, copied some of the raw files into the new folder, renamed all of the existing image folders I had been working with (to prevent PL2 from trying to open those again) and restarted PL2. My idea was to see if it was related to the number of images and I started by copying 10 image files. I had no problem. I went through the entire sequence again, removing the PL2 folder and copying more images. Restarted PL2 and had no issue. I kept this up, each time adding more, and the problem disappeared. Don’t know why.

One thing I ran into was that PL2 needed to download some raw and jpg correction files and I began to wonder if the download dialog box was hidden under the main display. Perhaps PL2 was simply waiting for me to download those correction files and I could not see the dialog box. Perhaps that was why PL2 was hung. Perhaps others might want to see if that is or is not an issue. Now that PL2 is working properly for me I can not recreate this issue, so others might check and see if this is or is not (one of) the issues.


#26

I was asked to send a diagnostic report. I did that but haven’t heard from support since. I have important assignments coming up and cannot trust Photolab2. It is heartbreaking but at the moment, my only solution would be to switch back to Lightroom. So much time and money lost…


#27

Lightning fast to launch since last upgrade. I never got any reply though…but if they were chasing bugs…


(David Page) #28

So, DXO support just contacted me to let me know that the issue has been fixed in release 2.1.2

I’ve just loaded that and tried again and fantastic, thumbnails load in about 1 minute, no hangs and everything is sorted!!! This was an excellent response from DXO support, they took ownership of the problem and fixed it. Great product, great service…