No hardwaracceleration on my Mac Pro 5.1 with AMD Radeon RX580

no hardwaracceleration on my Mac Pro 5.1 (Monterey) 12.4 with AMD Radeon RX580 with Vers. 5.3.0. !
the export with deep prime is sooooo. slow …
in my Activity App, the Graphiccard Window ist only Black. in the prefs of DXO I have selected my AMD Card.

1 Like

Hi there.

I guess you might already have solved your problem?

YES ! it was a special Setting in the open core patcher


Oh! can you tell me what is the setting I need to change ? I have the exact same problem.


1 Like

Hi Albert,
Are you able to list the “special setting” that you ticked in the open core patcher. I have recently updated to Monterey 12.6 on Mac Pro 5,1 and have the same problem with DXO 5.6 / 6 not utilising the GPU. I have hardware acceleration on all adobe CC software and VideoProc states that everything is working.
I had no issue on Catalina with open core patcher and DXO so a little stumped.

Hi Jerome, I understand you had some luck with the open core patcher if your happy to pass on any tips that would be appreciated. I tried to invite you to this the below page with no success.

Yes I managed to get it working with some advice from albertyy.

Open Core Legacy patcher does not allow full hardware acceleration using AMD GPU. To fix this, you need to use martin lo’s core.

Check post #1314 on this page :

Be sure to read carefully and watch the tutorial. I used OpenCore 0.8. You essentialy have to open your EFI partition and update the content of the BOOT and OC folders.

Here are some more info that may help you :

  • I also had to use the config.plist listed in the file download because I had random reboots after installing OpenCore 0.8. The plist file fixes the reboots.
  • On my setup, I have no display when using DisplayPorts. It works fine though using HDMI
  • I found out that some RX 580 revision have a switch that can be used to select 2 different bios. OpenCore works only with one of them (game mode I think)

Hope it helps!

1 Like


I managed to enable displayports (and multi screen) on my RX 580 with this fix

Everything works perfectly now :slight_smile:

Thank you so much Jerome, The solution was the martin lo config.

Great to hear the old gpu purr again.

Merry Christmas

1 Like