Nik update will overwrite old (Google) Nik

(Jim) #1

I’m running a 32 bit version of PSE which is only compatible with the Google version of Nik.

However, there are repeated popups offering an upgrade of Nik. The upgrade is 64 bit which is not compatible with older versions of PSE and will overwrite the 32 bit version of Nik rendering the plug-in useless.

I suggest the upgrade offer for 64 bit Nik in 32 bit programs be stopped.

Svetlana,

Here’s the problem: I have PSE 9 as the host for the 32 bit Google version of Nik. However, there’s pop-up offering an upgrade to the DxO 64 bit version. I made the mistake of upgrading which overwrote the Google version leaving a broken Nik.

The pop-up must be stopped.

(Svetlana G.) #2

Hello Jim,

You can still take the installer here - https://support.dxo.com/hc/en-us/articles/360001439187-Is-it-still-possible-to-get-the-free-download-version-of-the-Nik-Collection

As for your suggestion, @aisai , @Benoit, please, have a look.

Thank you
Regards,
Svetlana G.

(Jim) #3

Thanks for having this looked at.