Nik 4 and PhotoLine

I installed the latest version of Nik 4 and tried it with PhotoLine as host.
Analog Efex 2, ColorEfex Pro 4, Dfine 2, HDR Efex Pro 2 and Sharpener Pro 3 seam to work fine, they even support smart objects.
Perspective Efex works without smart object.
The problem is, that Viveza 3 and Silver Efex Pro 3 doesn’t show an “OK” and “Cancel” button. So I can’t use it.
What can be to blame for this?

The folks at PhotoLine are usually very quick to find solutions to problems like this. But here’s part of their response to a report of this bug on their forum:

They can’t help us solve this. There are so much bugs in the new plugins that they have no time for it.

After my earlier response to your message, I installed the latest version of the Nik 4 Collection and tried it in PhotoLine.

The workaround for Silver Efex Pro 3 and Viveza 3 is to install the standalones for those two apps as external editors in PhotoLine. They will run as layers in PL. After making the adjustments in either, go to the File menu and select Save. When the save is finished, quit the app, returning you to PhotoLine.

All the other Nik plugins can be installed as plugins in PhotoLine.