My DxO One suddenly cannot be discovered by iphone or DxO Connect app

Hi - I have tried connecting my DxO One up to my iPhone just as I had up to and including ios16. But then my DxO stopped being recognized by my iPhone. So I booted up an old iPhone running ios12.5.6 and downloaded the DxO app from the app store. The DxO One still could not be found by this iphone running the ios12. So I re-downloaded the DxO Connect software and despite the DxO one showing that it was connected to the computer on its back LCD the DxO Connect app told me the DxO One was not connected.
Also, I have tried to hit the reset button while the DxO is turned off and when the DxO is powered on and that reset button doesn’t help anything. In fact, pressing the reset is causing the DxO One to power down and then it isn’t restarting.
I do not understand why my DxO has suddenly decided it does not like me. It still takes pictures. It still records to the microSD but it just wont connect to anything.
I cannot seem to find a factory reset procedure. Does anyone know how I might get this DxO One to reset back to how it was working perfectly last week???
Currently, I am going to try letting the camera completely run out of battery and after I’m sure it’s drained I am going to let it fully charge and see if that has any impact. (Also, I have swapped out the microSD to check if that had an impact and it had no impact.)
If anyone is still checking this and has any constructive or creative ideas I would love to hear them.
Thank you in advance for reading and any assistance you might be able to provide.