Migrating palettes from PhotoLab 2 to PhotoLab 3

I created a couple of palettes complete with setings in PhotoLab 2. How can I migrate them to PhotoLab 3, to which I’ve just upgraded? In case it makes a difference, I’m using a Mac.

When I upgraded to PL3, all my PL2 custom palettes and workspace’s were automatically migrated to it. Are you not seeing that? I’m on Windows 10. While they may not be open by default after upgrading, user created palettes and workspaces should be available in the menus.

Mark

1 Like

Thanks for your quick reply, Mark.

Unfortunately the palettes from PL2 are not available in the palettes menu in PL3.

I’ve just tried to recreate one of them and it’s not being saved. For example, if I create a palette in the DXO Standard Workspace, it’s not available in any other workspace. And when I go back to the DXO Standard Workspace, it’s disappeared and no longer listed in the Palettes menu. Very frustrating!

Philip

You have to save any custom workspace.

I have saved a custom workspace and the problem persists. What’s more, I just closed PL3 and opened PL2 to see if I could save a custom palette there. All was working and then suddenly the palette menu refreshed, losing my custom palettes in the process. I’m wasting a lot of time here and moving backwards :frowning:

Philip

Hello
Self-adjustments are stored /library/DXP Photolab v2 / Presets /
If PL2 is no longer in service, to find them you have to search in Time machine, a backup with version V2 to find your palette.

Thanks. In /library/DXP Photolab v2 / Presets / I have found a preset but no palettes.

Philip

user/library/Application Support/DxO PhotoLab v2/Workspaces

Tom, in PL2 I hadn’t created a separate workspace so user/library/Application Support/DxO PhotoLab v2/Workspaces is an empty folder. What I need to find are the palettes I created in PL2. And beyond that, I’d like to be able to create and save palettes in PL3, which currently I am unable to do.

Thanks again.

Philip

I guess I didn’t get what you were trying to do.
I created a palette in DL3 and named it test.
It is there now and under Top Menu>Palettes, without creating a new workspace.

I’m not trying to be insulting by mentioning the obvious, but I have to ask. You did activate Photolab 3 with your new serial number after you downloaded it, correct? Just want to make sure you’re not in trial mode. I also assume you have not uninstalled Photolab 2 from your machine. Are there any presets that you created in PhotoLab 2 that also missing? One option is to reinstall Photolab 3.

Mark

No offence taken, Mark. Yes, I activated PL3 with my new serial number. I still have PL2 installed on my Mac. I created a single preset in PL2 and that is present and correct in PL3. But the palettes are gone and if I try to recreate them, they do not persist – they are not saved. I have a desktop and laptop machine. Both are misbehaving in the same way.

Philip

This is very odd. To my knowledge this is the first report of this behavior here. I’m not a Mac guy, but It seems like there is some kind of a lock on permissions somewhere which prevented your copy of PL3 to be updated with the palettes and work spaces from PL2 as well as the inability to save new palettes in PL3. The fact that its happening on two machines is especially weird. Are you running Catalina on both of your Macs by any chance? I know there have be a bunch of issues with a lot of software on that platform.

Mark

That’s a good guess, Mark. Catalina has thrown up all sorts of problems for many Mac apps. I’m a cautious upgrader so I haven’t installed it yet. I’m still on Mojave.

Philip