Issues with Nik4

Following your directions, I was able to uninstall Nik Collection 4. Fortunately I found a copy of Nik_Collection_3_by DxO.exe in my Downloads folder and installed Nik Collection 3. I was able to take an image from LR to PS 2021 and choose Silver Efex Pro 2. The image opened… Yay!!! DoX asked if I wanted to update (to Silver Efex Pro 3). At this point I declined. I have already paid for Silver Efex Pro 3 and Viveza 3, but I think that I will wait awhile before I take the upgrade. Wolfgang, you are my hero today!!! Many thanks for your help!!!

Tech support finally contacted me today. I provided them with tons of info and screen videos of me trying to open the apps - hopefully, something good comes of it. I am still a little bothered this is more a 25 % upgrade.

1 Like

I have had to do the same, support was no help it suggesting that work around

The new Nik Collection -I upgraded yesterday and Silver Efex Pro and Viveza do not work, on tiffs or psd files.
I keep getting an error message that “Disk is full” which it is not. The other programs work OK

I see several people reporting that “disk is full” error on this site. I guess tech support and the developers are still trying to figure it out. The more data they can obtain from customers through support.dxo.com, the better. Hope it gets resolved soon.

1 Like

I also have the disk full error, and have a ticket going. They know the problem. One thing I discovered: on my laptop only (not the desktop), I can open SilverEfexPro3 and Viveza from the selective tool - but NOT from the filters menu. Very strange. I’m running current ver. of Photoshop (updated today) and Windows 10, 64.

I have had no issues in installing or using the new Silver efex Pro or Vivesa in NIK Collection 4. I access NIK 4 from DXO PL4 Elite. Both my laptop and desktop have windows 10 pro as their operating systems. I have not used the other NIK plugins yet but will try Color efex Pro today.

Yes, I hate that bottom bar LOL!

Just installed the lates version of Nik 4.1.0 on Mac Big Sur plus latest version LR and PS as an update (installer says replace)
Stumbled on the same problem as mentioned above (No Viveza, No Silver Efex)
Went to Applications - Nik Software and saw that both were not installed.
Did a NIK un-install (including, remove older settings) and to be sure I deleted the Nik’s directory, did a clean install, and it was still not there.
So the first thing to do is GO to Applications - Nik Collections directory and check wether Silevr Efex and Viveza are installed.
If not (like me) re-install prior version 4.0.7
Hope this helps for now and save you some time.

I tried your workaround running the SilEfx plugin in Affinity Photo and PhotoLine. Resizing the window made no difference on my system (iMac Retina 5K, 27-inch, 2017; macOS 11.4).

SilEfx works correctly when an image is launched within DxO PhotoLab. It also works correctly when used as an external editor in PhotoLine. In both cases, the standalone is used.

When I open as smart object into Silver Effex 3 from PS, the program is frozen. When I open non smart object layer into Silver Effex I get ability to edit however when click apply and returning to PS the SEP3 effect is not applied. I have reinstalled Nik Collection and there is no difference to the issue. The one thing that has worked, is when “frozen” in SEP there is an ability to click on Services in Silver Effex Pro 3 menu. Once clicking on “services” the usual dialogue box for using smart object appears and edit can proceed. Please DXO fix the issue asap or advise me what to do.

I am also having problems with Silver Efex Pro 3 and Viveza.
I am using Windows 10 and Photoshop CC2022
When I try to use SEP3 I get a partial screen and the the program stops loading. I can exit out of SEP3, but I have to use the task manager to close CC2022 as it has become frozen.

Here is a screen shot.

I have continued to have problems, and just reverted to the previous version.

Using Windows 11 (latest release) on an 11th generation i7 with 128MB or RAM, and an nVidia a4000 GPU, so the system isn’t resource constrained in any way. Working from Photoshop 2022 (also, just recently updated). Tried re-installing the software and it made no difference.

I load an image the usual way: make the layer a “smart object” in Photoshop, then open SFX as a filter. It loads the image, but only loads the first 5-6 “previews” for presets on the left. When I select a preset, it does nothing.

When I cancel out or apply the changes, I can return to Photoshop, but then it hangs.

My guess (as a software developer) is that you’re making horrible use of memory, and probably leaking a lot and destabilizing the whole environment. May not be an issue with small images, but I’m working with 50mp and larger files. Try testing with a 10k x 12k image.

This was in 4.3.4. I’ve given up and gone back to version 3. At least it works. I don’t have time to waste on software that doesn’t seem to add any capabilities I care about, and doesn’t work.

hi @michaelgat

as a software developer maybe you can spend some minutes to check with sysinternal tools or the windows ressource monitor for some memory leaks and so on.

perhaps it help others also

I’m on an old Windows 10 system with 32GB Ram, but didn’t work with photoshop, and have no problems .
Only the time for exporting with deep prime is slow because of my old graphic card.

best regards

Guenter

I don’t do anything on Windows, and don’t have any Windows diagnostic tools, unfortunately. If it were Linux, it would be easy. :slight_smile: