Issues with DCP/ICC profiles

dfrmwk-15980

#1

Hello,
I’m playing around with the DCP profiles created by Adielle in dpreview forum (https://www.dpreview.com/forums/thread/4333279 and I’m having some issues. I’ve also created myself a dcp profile (using the RAW files from the dpreview studio scene for my Olympus E-M10.2 and the Adobe DNG Converter and the Adobe DNG Profile Editor) and I have the same issue with this dcp profile:

Applying one of the DCP in Photolab 2 to an image having a rather large dynamic range, I notice a lot of clipping.

What I do is:

  • Open the raw image in PL2
  • Apply the “no correction” preset
  • Select and apply the dcp file.

Using any of the standard camera profiles shipped with PL (generic camera rendering, neutral etc) I do not see clipping, but selecting any of the dcp profiles (I also tried the Huelight profiles) I notice the clipping.

I then used the dcp2icc tool to convert the dcp profiles to icc. On importing these, PL asks me whether the ICC profile has been created usinga linear or a realsitic reference. I tried both: with the linear option, I get correct colors, but the image is way too dark (histogram is very narrow and concentrated on the left half). With the realistic option, the histogram is also quite narrow, but now concentrated on the right half, giving completely wrong colors.

As this happens with all DCP profiles I tried, is there maybe something wrong with the handling of these profiles in Photolab? FYI: I’m using the latest version of Photolab.

If it’s not a bug in Photolab: what could be the issue?
Thanks!


#2

Hi again,
I did some further tests:

  • I’ve loaded a raw file in Photolab 2.1.1 having quite large dynamic range, but does not suffer from clipping using one of the DXO standard color presets.
  • Selected the “no correction” DXO preset -> no clipping.
  • Loaded the Adobe standard DCP profile for my Olympus E-M10.2 -> image shows clipping.

This seems to occurr with basically every DCP profile I’ve tried.

However, loading the same raw file and same DCP profile e.g. in Raw Therapee, I do not notice clipping.

So the issue seems not to be with the DCP profiles but with how DXO handles them. Does it maybe imply some sort of curve change?


(HTran) #3

Hello jdm,
I tried with your scenario by enabling “shadow/highlight clipping” options in Histogram palette and i see the clipping when applying DCP profile (created by Adielle and myself) . We will investigate on it to know what is happening.
I will let you know the result.
Regards,
HT


#4

Thank you!
As PL currently behaves when using DCP profiles, this feature is basically useless at least for me.


(HTran) #5

I added an issue to fix on our side
Thank you,
HT


#6

Thanks!
Hopefully, it can be fixed soon.


#7

I think the shadow/highlight clipping might indicate out-of-gamut colours, as well as luminance clipping. Since PhotoLab uses Adobe RGB working space the application of the DCP profile might be pushing some of the colours beyond Adobe RGB, that’s why the clipping indicator gets active. Do you use the auto function of the “Protect saturated colors” slider in the Color rendering tool?

I haven’t noticed this phenomenon when using Adobe DCP profiles for my camera. The only difference between DxO PL2 and Lightroom when using the same camera profile and all else disabled is that the black subtraction in PL seems to be different than in Lr (increasing shadow contrast a bit). Also WB is calculated differently by the two applications, but apart from that the new DCP support works quite well for me.


#8

Hello,
yes, I used Intensity 100 and “Protect saturated colors” was set to Auto, WB was set to “Original”. No other correction has been applied.
I’ve tried with the profiles provided by Adielle (first post), with profiles I’ve created myself, with Huelight profiles as well as with the Adobe standard dcp for my camera - each dcp shows the same: considerably more clipping than any of the dxo standard color presets. I was wondering why “protect saturated colors” did not help.


#9

FYI: My PL version is 2.1.1 Elite Build 23555 (Windows).


#10

Here are two screenshots of one file opened in Lr5 and DxO PL2. In both I have disabled everything there is to disable and applied the same Adobe Standard DCP profile for my camera.

First, the screenshot of PhotoLab, with the Shadow clipping indicators ON:


Second, the screenshot of Lightroom in the softproofing mode, with the Adobe RGB profile set and the out-of-gamut warnings.

As you can see, both show more or less a similar area outside of the Adobe RGB gamut. PhotoLab has crushed shadows a bit more, but the reds/pinks in the photo are not extremely dark, so my guess the Shadow clipping indicator in PL also performs the out-of-gamut function.


#11

Interesting. What would be the solution then? DxO switching to ProPhoto?
This is a screenshot where you can see some clipping warnings even with DxO standard preset:


Just the raw file loaded, then applied DxO “no correction” preset to turn everything off and to use the camera standard color preset.
(following in next post)


#12

Next, just loaded Adobe standard dcp for my camera:


As you can see, a lot more clipping warnings.

Edit: funny, just looking at my screenshots again, notice that the auto-chosen “protect saturated colors” value is lower than in the first image, and at the same time has more clipping. But even manually pushing it to the max value, it still shows more clipping.


#13

The clipping warning in your first screenshot looks like out-of-gamut warning for the deep yellow (yes, the Protect saturated colors slider didn’t manage to contain the gamut). I think having ProPhoto working space would help if you wanted to print the photo. The second screenshot indeed shows a tonal shift resulting in greater contrast and clipped shadows and highlights – part of the problem can be explained by the wrong black subtraction applied by PhotoLab (see the link in post no.7 above).


#14

Hello Sankos,
you are right. Part of the problem can really be solved by disabling automatic black level subtraction. But only part of it unfortunately. I’ve decompiled the Adobe Std dcp using dcptool, disabled the automatic black level subtraction (i.e., setting the “DefaultBlackRender” tag from 0 (Auto) to 1 (disabled), and compiled it back to dcp. Compare the results to the previous screenshot:


Still some clipping, but certainly less.


#15

Nice. I think it should be relatively easy for the DxO team to fix the black level subtraction thing. Hopefully highlight clipping will be addressed as well. I don’t see clipped highlights when applying DCP profiles in my photos because I’m not very aggressive about my ETTR, having a nearly ISO-invariant camera.