Help! DxO very slow on new PC, don't understand

Hi there,

I really need some help here. On my previous 16GB/i7/GTX1060 build DxO Photolab was very snappy and responsive, loading large images collections with a good speed.

Now I built a brand new 64GB/i9/RTX2080Ti machine and it’s really starting up very very very slow. Sometimes after start-up not even loading the imagefolder, or after a long time with a crawling speed of 2 or 3 images per 10 seconds.

It’s not DxO, the same version runs great on my other machine, it can’t be the build since it’s just blazing fast in other things and it’s not the media-drive (external 4TB USB 3). The same drive used on the older machine just runs smooth and DxO loads fast.

What am I missing here? Where can I look for a solution? Can it be a antivirus conflict or anything? I’m at a loss, any help appreciated.

best regards, Frank

Hello @Frankster69,

It’s really strange as your new machine is powerful enough.
@alex, could you, please, assist here?

Regards,
Svetlana G.

Hello,
I have had this experience, i think it was end last year or beginning this year, at my notebook with fresh Win10 installation (maybe Steve remembers). The contemporaneous installed Desktop with same Win10 version and also actually patched doesnt have had this problem. A lot of mail and hijack reports between support team and me follows. Didn’t find a solution.
With every MS Patchday I tried again, and then sometimes the problem was gone. I think it was after the march patch.
During the whole time other programs at the notebook like Affinity, Raw therapee and other programs where fast as before.
No idea what cause the problem.
@Frankster69 I know that didn’t help you, but maybe it’s a good idea to check if BIOS Version, drivers and patches are up to date.
good luck

Or it’s the setting for the database and/or Cache folder in the preferences.
If they are at the standard path anywhere at C:\ drive, they have to build again.
And maybe it’s a thing like Fotothek "Time consuming"

But only presumption…after a lot of years using DXO I haven’t understood the internal way of working :rofl:

Since your computer’s a new build, I suggest:

  • make sure your hardware drivers are all up-to-date;
  • try a different USB port and cable for your media drive;
  • run some benchmark tests: search the Internet for ‘hard drive speed test’ for some ideas;
  • for testing memory, I used to use the software at memtest.org;
  • try Intel’s diagnostic utilities to see if your CPU is performing properly;
  • check power management settings in Windows: try high performance mode if you aren’t already using it to see if that makes a difference.

You are using UEFI for startup, right? Everything OK with that? BIOS settings look OK? CPU temperatures look OK? (A hot CPU could cause a severe throttle down in performance.)

Have you tried launching Task Manager while the slowdown is in effect? I had a similar problem and discovered an unnecessary program was hogging all the resources.

Hell @Frankster69,

if the problem still exist you can try the steps from https://answers.microsoft.com/en-us/windows/forum/all/slow-computer-after-downloading-windows-10-update/f5babd0a-3320-4f88-9809-73c8c85880d6

Open Start, type: CMD - Right click CMD and run as administrator

Type in at the prompt: (Hit enter after each command)

Dism /Online /Cleanup-Image /CheckHealth

Dism /Online /Cleanup-Image /ScanHealth

Dism /Online /Cleanup-Image /RestoreHealth

Also run the System File Checker utility:

Open Start, type: CMD - Right click CMD and run as administrator

type: sfc/scannow

This will check for any integrity violations

Restart your system

Guenter

Hi - could it be related to the problem described here by Robin Whalley:

https://feedback.dxo.com/t/performance-problem-and-fix/13474

The problem he has been having seems to be related to DXO PL creating lots of new .dop files, for every image, following an update. It has happened with his Mac and Windows machines. Read his post for a possible solution to explore. Though others have not been able to duplicate the problem.

Nigel