Generating preview

…and some sensible caching too…

2 Likes

Tag your post with “bug”.

I may be confused about this issue. I run DXO PhotoLab 2.2.1 on an i7 Windows 10 machine with 24GB of ram and an older Nvidia 745 card and I see none of this blurriness issue as described. I originally thought this was a Mac only issue until I saw your post.

When opening an image it takes around 3 seconds for a previously edited one to have all the settings applied to it and for the spinner to stop. For no more than a half-second the image is a bit blurry and for the remaining 2.5 seconds the image resembles the unedited raw file until the edits are fully applied. For unedited raw and jpeg files, or jpegs with saved edits, it also takes no more than a half-second for the image to stabilize.

If I am zoomed in above 75% and change to a previously edited image it takes around 3 or 4 additional seconds for all the edits to be applied, but tit still only remains blurry for around the first half second, For unedited raw and jpeg files above 75% zoom it takes slightly longer than at below 75% and is still blurry for a fraction of a second

Is this conversation about something other than this? I don’t see this as a problem at all. Is this problem related to very large TIFF files perhaps? I can comfortably live with the current half-second of slight blurriness when an image is opened.

Mark

Yes that is the issue, the lengthy fuzziness of the image. But you are still on 2.1.1 and I did not notice this behavior (or it did not bug me so) until 2.2.1.

My images are 24mp raws on a MacBook Pro w/ 16GB memory and 8 cores. Little bit less beef than your Win 10 machine, but plenty to go around.

I am on 2.2.1. My error! It was a typo and I will go back to correct my original post. I was initially thinking that this could be a Mac issue until John7, who is also running Windows 10, indicated he was having the same problem, although he does not mention the blurriness. Since I also don’t have this problem on my less beefy laptop with 16gb of ram, I’m guessing it may be a Mac only issue after all.

Mark

I have the delay in PL loading the images, not much blurring that I can see. Its always been slow at loading, Lightroom, as I remember was much quicker but given it came from being a DAM origin I am not surprised and it may not have to do so much processing. i also recall Lightroom was re written to speed it up before I stopped using bit so may be the programing was better written than PL for loading images as well.

Hi,
I noticed that this problems starts when you activate the “Customize” mode.
You can try the following :
If you start PL2 in “Photolibrary” mode (means quit previous session in Photolibrary mode), you will notice that the navigation in the library is normally fast.
Then if you go “Customize” button, the loading becomes very slow.
Then if you come back to “Photolibrary” the loading stays very slow.

My version is 2.2.1 build 30 but I have this problem since black Friday 2018, when I upgraded my DxO OpticsPro 11 license.

4 Likes

Hi,

I run DXO Photolab 2, version 2.2.2, on a MacBook Pro 2015 ( Core i7 2.2GHZ, 16GB Ram, SSD),
and noticed also some slow down when opening RAW Picture :
My pictures are coming from a NIKON D750, 24 MPixel. a raw file is about 30 MB.

when using DXO on MacBook Pro without external monitor :
I found a way to speed up a little bit the “correction preview” step :

I set my MacBook Pro in default screen size, instead of using the Retina resolution.
then, the picture are opening faster. not as fast as Lightroom, but really faster : around 2 seconds only to be ready to manage.
I use this tips to rate, and reject photos.
then, after that step, I switch back to retina, to “develop” the pictures.

Hope this could help.
Thanks
Olivier

2 Likes

DxO says, that opening DPL in low resolution mode helps speed things up.
To do this, right-click on the DPL icon and open the info dialog. There you can set DPL to open in Low res. mode.
See towards the end of this post: https://feedback.dxo.com/t/photolab-considerably-slower-than-op-11-and-op-10/1920/25

This is a great tip. At the same time photographers did not buy 4K monitors and €200 darkroom software to work in low resolution. DxO PhotoLab is wonderful software but it really needs proper optimisation to work at full speed on modern hardware (I’m on a Mac 12 core tower with a Radeon RX 580 with 8 GB of VRAM and 128 GB of RAM)so there’s no shortage of GPU or CPU or memory). Sony A7 III files are acceptable but not instant, Canon 5DS R files process with the fluidity of molasses on my system at full resolution.

Alec, which card are you using, and do you get the boot screen with it?

I named the card in my post, Scott.

You named the chip, but a number of OEMs build a card with that chip. I was asking which one you were using and whether the firmware supported display of the boot screen.

I am new to Mac PL2 and noticed exact the same issue of long “correction preview” step with v2.2.2 (thus I searched online and found this thread). There seems some issue in the preview caching logic. In the Library mode, if I go through the photo one by one, it takes a few seconds to finish “correction preview” for each photo, which is acceptable for first-time rendering to generate preview (and cache). Then If I move backward to the last previous photo, the rendering is instant, which makes sense as the preview should have been cached. HOWEVER, if I move backward further to another previous photo, it would take a few seconds to finish “correction preview” again, which indicates the preview cache seems to work for last single photo only but not more than one photos in this case. It is unrelated to cpu/gpu/etc. but just the cache behavior seems weird which may indicate possible caching bugs.

3 Likes

I have notified such behaviour with the recent builds, I can’t remember with which build number it starts but the difference was blatant, and unfortunately it makes working with PL not as pleasant as before. Is there a way to report the lags to DxO ?

For information, I’m using PL on a 2018 MacBook Pro (i7 2.6GHz, 16Go RAM, 512 SSD) and I didn’t encounter this issue before.

3 Likes

Sapphire Pulse Radeon RX 580 8192 MB RAM, device ID 0x67df. No it doesn’t support boot but this is a real Apple Silver Tower so there’s no special initialisation or kexts required for full support. The card does occasionally throw a single frame reset on the 4K monitor if frame rates disagree seriously enough with video playback or multiple applications struggling over the graphics card. It can days without doing so as well.

2 Likes

Can we tag this post with “bug” as Tom suggested please? There is clearly some bug causing preview cache not to work and we can get repro of the issue 100% times. The long preview lag bug can be a deal breaker for many users, Hope DXO can take a look. Thanks.

3 Likes

Please test after temporarily switching to a default theme. If that doesn’t help, please switch your theme back and and temporarily disable all plugins and test again—if the problem is still happening for you at that point, please ask to re-open this issue walgreenslistens.

Default theme for … what? PL2 has themes? And plugins, you mean like FilmPack and ViewPoint? Not sure I see how these would be impacting this issue. I do have both of those.

I’m still seeing PL2 not responding to changes in the edit controls. It is impossible to predict but it shows up as making a change of some sort, and seeing no updates on the screen.

Hi, Just checking back as I’m evaluating PL2, and more than anything else, the fuzzy previews start to bother me after navigating through a few photos.
Is there a way to make PL2 save the previews in a cache? I am scared to even suggest this, because of the horrendous mess that cache causes in other softwares. But… fuzzy wait…

Maybe, PL2 could allow me to select a batch of images, generate a preview cache for them, so that I could navigate through just that set faster? It doesn’t have to be zippy for all my hundreds or thousands of photos at one go.

3 Likes