DxO Shop Account, License Keys & the Lot

I posted this info in this forum, but it’s a general topic that could also reside elsewhere…

I log into my shop account every now and then the get the license key for a new installation.
I found that the page has changed from a long standing layout to the current layout with the white boxes. There was an intermediate layout with additional information, notably the number of registrations per key, which was useful, specially with “Essential” editions.

I also found that the current layout seems to not show all the products I had/have license keys for.
In order to prevent loosing the possibility to fall back to an earlier version of a product, I always keep the installer and the mails with the license keys as well as a file with the respective license keys, which I keep in macOS’s keychain app as a secure note.

If you’re searching for license keys in your eMails, the following info might be useful, it helped me to find the mails with the respective informations…
DxOProductNumbers.txt.zip (860 Bytes)


I found that I can’t even log in using Opera anymore and have to use Edge. Having to use a sperate browser to log in is really poor web building.

I don’t know about Opera, but you can also log in via Chrome. Of course, Edge and Chrome are now both Chromium based and seem to be more similar then different.


Opera is Chromium based too

Just done a quick check

Shows PL2 and PL4 but not PL3
Shows NIK 3 but not NIK 2

Like you, I have the emails saved (for all my softwares in fact)

Actually I had the same issue with the latest version of Firefox when I tried to get into my account to download Nik 4: impossible to log in, had to use Edge to access my account.

1 Like

That is not good.

Using Edge for some time now. I can’t even log in to my Store account. I enter my username and password, click on “Sign In”, and the same login page reloads.

I tried again from the main dxo.com page and got this error:
Something went wrong with reCAPTCHA. Please contact the store owner.

I’ll try to report that if it isn’t fixed tomorrow. Chances are that it’s being worked on already.

I logged in via Chrome a short while ago with no issues. I just tried logging in via Edge and got the same issue as you. I then tried logging in using Chrome again and this time I got the same issue as I did with Edge. It is obviously a site problem.


I had no trouble logging in with the Brave browser, also Chromium-based.

Safari and Duckduckgo browsers works too.

always use Firefox - no problem

I also am now having trouble logging in to my account. Worked fine until the last few days. When I log in, it just refreshes the screen and tells me to log in for access to my licences. I also had trouble logging into the forums just now and had to use an emailed link. I use Win10 64 and MS Edge. What’s going on? I’ve contacted DXO support and am awaiting a reply.

I have exactly the same issue, same software, same timing.

Same here. My standard browser is Firefox but that does not work to log in. Had to use Safari instead.

1 Like

Edge on my phone works at the moment. Store login successful, saw the licenses that I expected to see. Never did have a complete history there.

Chrome on my Windows 10 setup logs in fine and correctly displays the DxO products I have purchased through the Shop. For a couple of them (ViewPoint 3 and FilmPack 5) it stated I may not have the latest update installed (although after checking each I did).

Using Firefox i see the products and the licenses. BUT: I can´t activate the software with this information and since 14days the DXO Support is unable to fix it. Links to the support topics are broken and they don´t react to emails.

Hello guys,

I will try to notify the dedicated team about it. Thank you

Svetlana G.


Windows 10 21H2
Edge v91

No issues logging in .