DXO PL 4 doesn't seem to support rhe Sony A7R IVA RAW files

It is possible that somebody in the DXO support team hasn’t seen that Sony has released a new version of the A7R IV. The bew model name is: A7RM4A
This seems to make a difference when DXO PL 4 reads the EXIF file and seems to refuse to recognize the RAW format. This has been verified by an EXIF knowledgeable person who reported this in another forum.
Other applications like AFFINITY or Sony’s own Imaging Edge work fine with the new Sony model…
Can DXO fix this quickly please? Could be a minor intervention which has a huge impact on users of the application who actually are left stranded and have stopped working !

1 Like

Yes, the DxO team is aware of the A7R IV A and that it’s not supported yet in PhotoLab and PureRAW. It was discussed in another thread in this forum:

You can request support for the camera/lenses here:

Supported Cameras - DxO

You can also try modifying a RAW file using ExifTool (if your OS can run it) to see if that convinces PhotoLab to treat the file as if it were taken with the A7R IV.

Thank you,
I have tried the ExifTool directly via the Terminal and by using the SetExifData UI (which in turns uses the ExifTool) but something makes that it doesn’t work. I have changed all the occurrences of AIVa to AIV but I may have missed something else.
At the moment I’m looking at using a temporary workflow involving Affinity and Sony Imaging Edge applications while shooting at low ISO so that I don’t need to use the Deeprime / PureRAW functionality. The alternative would be to go over to LR and PS (which support A7RIVa since June) but that would mean a new learning curve. I’m waiting to see if I can get a date for the changes to incorporate A7RIVa from DXO…
Best regards,

You need to set the camera to ILCE-7RM4 with Exiftool

It should work. I did this with Sony A1 files before the A1 was officially supported and it also worked on the A1 files.

Thank you Greg and MikeR,

Yes it does seem to work now. Late last night with the help of 2 forum members of AlphaDXD we made it work. The reason it didn’t seems to be that Photolab was still active between the 2 trials I made. When I instead turned off Photolab and restarted it worked.
So this seems to a good temporary solution and I will make a donation to the people who developed the two tools (ExifTool and the SetExifData GUI) because they really save time for us, the users.

Best regards and thanks again for your contribution,
Roger

1 Like

Hello,

we have added the Sony A7R IV A to the roadmap.

I’ll keep you updated for its support.

Regards,
Marie

This thread is over a month old. I purchased DXO software previously and spend a good sum of money. Will this PoS software ever support newer cameras such as this Sony? This is getting to be unacceptable. If you are going to charge hundreds for the products you push, you should support the new technologies. I’m sure you knew about it before it was even announced or available for retail. SMDH! And NO, I’m not willing to edit thousands of EXIF files. At least revert back to an older camera version. I’m sick of seeing error messages and not able to edit anything. I might as well delete the software and you should issue refunds.

1 Like