Canon lenses no longer recognized

I have a Canon EOS 90D and since the so called upgrade to 5.1 I can not longer edit the raw images for pictures taken with any of my lenses. They all work with version 4 of DXO. Anyone else having a similar issue. I have had a case open for over a month with no end in sight. This upgrade has so far been a total flop and I am not impressed with their support.

Are you being prompted to download the lens modules? I don’t think that they migrate from v4 to v5. Even if you don’t have the lens modules, you should still be able to process the RAWs, just without the lens corrections.

I had this with V5 a sigma 150 macro, they had to do an update to get it to work again. Why 5 has so many problems is beyond me!

The optic modules carry over from version to version.

@Tugoldens are the modules offered when you click on a photo?

There is a preference that prompts to download optics modules on a image when a supported optic module exits. If disabled, you won’t be prompted.

Also wondering about your upgrade process. Did you update PL v4 to v5.1. Please provide more detail about your upgrade process. Example, ran 5.1 upgrade over v4 install or do you install individual versions that co-exists.

I suspect there is a explanation for the behavior you are seeing.

Are you using windows?
Modules should exist here:
%userprofile%\AppData\Local\DxO\DxO PhotoLab 5\Modules

Thanks for the info.

Are you sure? That was not my experience when I updated PL3 to PL5. PL5 had to redownload the various lens & body combinations that had previously been downloaded and used by PL3. It did that automatically / painlessly, I just got the usual prompt / notification whenever PL5 needed an module it didn’t have.

1 Like

Greetings,
Mine have carried over since PLE v1. I’ve expanded the number of modules as the number of lenses I owned have increased/changed, but all of my original modules from my very first camera and lenses are still with me.

1 Like

The modules seem to be the same in v4 and v5. I cannot even open the RAWs in v5.

Thanks for responding. I have both v4 and 5.1.2 and the lenses work perfectly in v4. In V4 if I don’t have the proper optic module it prompt to download but it does not in 5.1.2.

I even have 2 computers and I get the same result in both computers (ie. works in v4 but not v5).

The module files appear to be the same in both versions and I have verified the location. The one thing I did notice is that the naming is slightly off on the plug in. For example, the plugin name starts with “EFS 17” but the raw image says “EF S17”. I have pointed this out to support but didn’t hear anything back.

Good Morning,
Are you saying that you cannot open RAW photos in v5.1.2?

They preview in the Filmstrip, but don’t open if you click? There are no reports of an inability to open .cr3 files I am aware of except yourself.

That is correct. I can open .cr2 files that were taken with my Canon ti3 but not the .cr3 taken with the D90. I get the same result on 2 different computers. I have uploaded several of the RAW files to support but my case has been open for over a month and the only time I get a response is when they release a new update.
One thing I did notice is that when I look at the image properties in version 4 of the software it lists the lenses as “Canon EFS….” But in version 5 the lense is “EFS….”. This is for the exact same image.
Totally baffled by this one. How could I have the same result on 2 computers and be the only person.
Thanks for all the responses.

Ed,
Please upload a .cr3 file I can test in v5.

My 6D2 saves RAW in .cr2.

Thanks

He’s got a 90D

I don’t know if Canon ever made a D90… Thinking not.

Umm, as far as I know there’s no such Canon camera called the ‘D90’. There is a Nikon D90 though and there is Canon camera called the ‘90D’.

I have a Canon 90D and PL3 and PL5 (I skipped PL4) both handle .CR2 and .CR3 files with no errors.

Yes. They never made a D90… I just confirmed.

I am very familiar with the 90D… and @stuck says his .cr3 files open just fine.

@Tugoldens (Ed). You’ve got something else going on.

You are welcome to provide a copy for us to try.

Sorry I made a typo. It is a 90D. When you say provide a copy. Do you mean upload a RAW file? I could share a Dropbox link to a RAW file.

Raw Image

Link to a dropbox raw image

I can confirm that this RAW file will not open PL5.1.2 Win version.

Is this a raw or c-raw file?

Mark

when I click on this link I get an mp4 video file and not a raw file.