Canon EF 500mm f/4L IS USM gets wrong DxO Modules

#1

The Canon EF 500mm f/4L IS USM is shown as an EF 500mm f/4L IS II USM.
With an 2* Extender, it becomes an Sigma 500mm F4 DG OS HSM with EF2x III.

Maybe it’s a problem which can be solved if Option to manually select a lensprofile is realized.

1 Like
(Svetlana G.) #2

Hello,

Thank you for the report. @Marie could you, please, have a look?

Regards,
Svetlana G.

(Marie) #3

This issue is due to the fact we don’t support the Canon EF 500mm F4L IS USM (yet).

To match an image and a module we use several Exif/MakerNote information in following order:

  • LensName
  • LensID
  • LensInfo (for example : 18-35mm F3.5-5.6)
  • Current information of focal and aperture

Information 1 and 2 are not always available (especially for cameras of old generation).
Any of this information could fit several lenses (1 and 2 are supposed to be unique but all makers don’t respect that).

So when a module for a couple doesn’t exist yet PhotoLab can propose a module for one or several other lenses.

For now we support :

  • Canon EF500mm F/4L IS II USM (it has probably same LensID as model I so we propose it)
  • Sigma 500mm F4 DG OS HSM S
  • Sigma 500mm F4 DG OS HSM S with EF1.4x II
  • Sigma 500mm F4 DG OS HSM S with EF1.4x III
  • Sigma 500mm F4 DG OS HSM S with EF2x III (that’s the only module with same lensInformation so we propose it)

Regards,
Marie

1 Like
#4

Thank you for your explanation. At home, I will look at the values for my lens: