Bug: Crop corrupts repair brush Photolab 3.3.2

When I apply repair brush to a cropped image the repaired areas move in the image
I need to do the repair on the full image and then crop which means I am not totally sure if what I am doing is inside or outside my crop

It’s a known problem. At the moment the solution is in your workflow. https://feedback.dxo.com/t/auto-mask-not-adjusted-with-perspective-correction/12995

1 Like

Am getting an error Page not existing or private when I click that link. Can someone past the post here or tell me how to read it?

The problem is masks don’t move. Therefore, if a mask is applied and another correction such as perspective or crop is applied, the underlying mask can be seen. The solution is to apply masks after any correction that moves the image.

I am finding the opposite corrections do not work at all after crop is applied
I need to uncrop apply correction and then crop again

@Interceptor121, can you provide a screen capture that shows what your whole workspace looks like when you’re trying to use the repair tool without success? Or a video that shows what you just described? I’m not having any such problems with crop and repair.

Video link here.
https://drive.google.com/file/d/1Rc1Dnny_71up4cx9Ri-azBOAIAVsAzTT/view?usp=sharing

In order to make things work I need to reset the crop reapply all repair and then crop or the masks start moving on the screen as per video

It looks like the crop tool is off, and yet when you activate the Repair tool the crop boundary is showing.

It would help to show this happening with the existing masks visible, since the repair tool in Repair mode seems to be moving those masks.

Also, I see that this is on Mac. What MacOS, etc.?

The image is cropped as it is 1:1 instead of 4:3. You can’t keep a mask on when you press apply it crops it
I am on mac OS I cant comment on windows version the behaviour is the same on both my machines

I get the same error when clicking on the link.