Banding in Photolab

Hi - I have recently been trialling various image processing applications in my search for an alternative to Lightroom.

So far, Photolab is looking like the best alternative, but now I have run into a problem and would like your advice. I shoot RAW and jpeg using a Nikon D750. Quite often, I work on the jpeg images in the name of saving disk space and convenience. Using LR, I find the quality to be excellent and the results more than satisfy me, even when printing anywhere up to around 16x20 inches. I have attempted to follow this approach with Photolab, but am finding severe banding appears in skies and areas of subtle gradient. This has not appeared when ising ANY other software - Lightroom, ON1, Exposure X5 and now RawTherapee. There is no sign of such artefacts in the original jpegs.

Does anyone have a solution for this problem - beyond restricting myself solely to RAW shooting, which I simply do not need for Facebook or more casual shots?

Hello @chrisp172,

To discuss your problem we need to see it at least. Could you, please, provide us with the screenshot of the problem and some of your problematic .jpeg images?

Thank you,
Regards,
Svetlana G.

How many bits per channel are your JPEGs? If they’re 10 bits per channel (30 bits overall) then the banding could be due to the fact that PhotoLab only works in the 8 bits/per channel space.

1 Like

My understanding is that the JPEG format is 8-bit. If you need a compressed format that supports more than 8 bits per channel, something else is needed such as TIFF or HEIF. And regardless of bit depth, the compression itself, if lossy, can result in posterization/banding.

But the concern seems to be that this is only being seen in PhotoLab with the same JPEGs that aren’t showing banding in other viewers/editors. There could be various causes for that. PhotoLab’s image adjustments aside, if the monitor/graphics card are 8-bit and are using an ICC profile, then the color/grayscale corrections can produce banding in gradients such as sky. Could it be that PhotoLab is using an ICC profile that the other applications aren’t?

If it’s an adjustment in PhotoLab that’s introducing the banding, then I suggest trying to isolate the specific adjustments that are doing that. Could be vignette correction, noise reduction, smart lighting, color rendering… lots of possibilities.

Sorry for the confusion regarding the file format. Attached is the problem image. Derived from a Nikon D750 jpeg. Crop of the sky. I hope this uploads correctly.

Hello @chrisp172,

Okay, I see the problem. Could you, please, provide us with the original images via upload.dxo.com (as here the image data is removed) under your forum name instead of the “support ticket number” and let me know when ready.

Thank you,
Regards,
Svetlana G.

Original colour jpeg has been sent. Thanks for looking inot this.

Thank you. Got it.

Regards,
Svetlana G.

This is a work-around, not a solution to JPG banding of blue skies (or any smooth area with a color gradient.) Use the automask tool in Local Adjustments to mask the banded area. Then tweak the Blur and Sharpness tools to blend the bands. Not very elegant, but it works.

Thanks - a good tip, but I would be concerned about losing details in my skies by using blur.

Tbh, I don’t think it should be necessary as the banding is not present in the original files and does not occur when I process in other applications. Thanks for the suggestion, however :slightly_smiling_face:.
.

I observed the same problem with my raw.
no problem with Lr or affinity or DPP

Hello @chrisp172,

Could you, please, also attach your sidecar here? As with the default corrections I can’t reproduce it:

  • Please, provide me with the image+sidecar as well.
    Thank you,
    Regards,
    Svetlana G.