Applying preset with Unsharp Mask does not turn on the block

I created a preset with only HQ Noise Reduction and Unsharp Mask defined and enabled.

When I apply the preset, the HQ Noise Reduction applies as I expect, but while the slider values in the Unsharp Mask block are set correctly, the block remains disabled. I removed and carefully recreated the preset and it still happens.

Furthermore, investigating the preset file shows it does have the block enabled. It just doesn’t happen in PhotoLab when applied.

Also, that intensity value! Slider shows 165. :grinning_face_with_smiling_eyes:

Did you do so manually (using a text editor, or similar) - or did you use PL’s inbuilt Preset Editor ?

If the former, I suggest you repeat the process in the latter - to determine the difference.

John M

I created the preset first time from the above photo once I had it dialled in where I liked it. I then edited that preset to remove all but the noise and sharpening.

The second time I went to a fresh photo and applied just noise and sharpening to those values and created a new preset, before editing and removing all other blocks.

In both cases when I apply the preset to another photo, the sliders have the correct values but the block remains off. The editor view above was just to prove that the setting was correctly stored in the preset file. This is true whether applied from the presets block or from the menu and whether to a single or multiple photos.

If you have PL Elite you can start with an empty preset and add only the blocks you want to create a partial preset. Otherwise fiddling with preset files is the price you pay.

I do have PL Elite. I didn’t realise this was a limitation in standard? I create a new preset from the current settings, then edit it to remove those blocks I do not want included. Is that not the way on standard?

I’ve not noticed how to create an empty preset. I should probably read the manual on this.

In Standard you can’t create partial presets. But you can edit the files and effectively create partial presets this way. It’s tedious and error prone, though, and I can’t recommend it. I assumed that’s what you did because you showed the text editor.

For special presets like this I like to start with an empty preset. It’s easier than to switch off all unused blocks from a full preset. Also before PL4 it was not possible to remove local adjustments from a full preset.

I will try to replicate the issue you described.

2 Likes

I did this:

  • start with an image with all tools switched off
  • create a new empty preset
  • edit the preset and switch on HQ noise reduction and unsharp mask tools
  • also move the sliders a bit in both tools
  • save the preset
  • apply the preset

Actual Result:

  • HQ noise reduction is switched on
  • unsharp mask sliders are moved but the tool is not switched on

Expected result

  • HQ noise reduction and unsharp mask tools should be switched on

This really looks like a bug.

@sgospodarenko Svetlana, would you forward this internally?

Edit: preset created in the test with PhotoLab 4.1.3 Build 49, macOS Big Sur 11.2.1
test.preset (656 Bytes)

1 Like

Good morning @Calle,

Let me invite @kettch instead and he will analyze it.

Regards,
Svetlana G.

Unfortunately, I cannot reproduce that one, but I may not be in the same case as you are. To try and pinpoint it, could you give me a bit more details:

  • What is the status of the Lens Sharpness in your preset? (enable / disabled / not present)
  • What image are you applying the preset on? (RAW/JPG)
  • Does that image have a valid module?

Thanks!

From my experience of the same issue, I was applying to a 48-bit TIFF file from a scan so there was no module nor therefore lens sharpness. My default preset for RGB images is “No correction” so all other blocks would have been off.

Well, I did find something that forces the Unsharp Mask off when applying a preset, if the image it’s applied to is not a RAW image… There might have been a reason for that years ago, but since no one remembers it, we’ll be removing that for the next release…

In the meantime, you can still apply it manually, and this should be fixed soon!

1 Like