Adding and editing searchable keywords

Although I don’t like the approach, but IMatch writes the keywords into the RAW files and many user praise it.

As far as has been discussed in different posts, keywords are added to the DPL database - but not to the .dop sidecars.

1 Like

I don’t know of that.
But I just tried to export a nef with keywords added in dxo, the keywords are not added to the jpg.:flushed: I just assumed that to happen.


On previous tests I found that keywords are added to the output files. Please test again carefully. If output file still contain no keywords, you might want to restart your C and/or reinstall DPL or call DxO support.

Something strange is going on.
In PL1 the keywords are saved, I mean those I added before to the nef.
In PL3 the existing keywords are saved now too. Maybe my fault.
On 2 pc, one with a fresh install of both .Network and PL3 the in PL3 added keywords are not saved in the jpg.


Did do some searching. Not able to add Keywords in Elite
Seems to be a known issue and should be resolved in 3.1. I don’t think so.:pleading_face:


  • Yep, the keywords are not added to the dop file, they are stored in the database.

Svetlana G.

Hello @George

  • It’s seems to be an issue as you can do it on one PC and can’t do it on the other. Please, create a support ticket as @platypus recommended you.

Svetlana G.

I really don’t care where the keywords are added, more where they are NOT added. Always good to know however.They’re not added to the exported jpg file. I still don’t know if that is the right behaviour.
Keywords that where added to the raw file before, are used as expected: they are read and processed in the export function.
That happens on both pc’s. A win10 and a win8.1.
So the main question will be: are they added tot the exported jpg and if so where?


Yes, they are added directly to the outputs:

I’ve added the keyword to the RAW image and processed it -> as you can see the output has the keyword.

Svetlana G.

Yes, they show up in windows. And I found them in exiftool under the tag name ‘subject’ but not under the tag name keywords.


PS. Exiftool GUI doesn’t work on my win10 pc. Asking for a feature I would like to see: write the IPTC data also.:grinning:


Can someone please clarify whether keywords already added to EXIF data of the RAW file should be visible in DxO? Or is it only if there is an XMP file accompanying it?

I don’t use Lightroom or Photoshop, thus I don’t have ready created XMP files. But I can use macOS Finder tags or Exif Editor to add them to the RAW file; but neither IPTC nor XMP keywords are picked up but DxO.

Since this thread is under wanted features, can I ask for something out of the following -

  1. DxO reads macOS tags
  2. DxO reads IPTC keywords from the EXIF
  3. DxO reads XMP keywords from the EXIF

It would also be very useful if DxO updated the original source of found keywords, as well as adding them to the database.


Je ne comprend pas pourquoi il faut dupliquer une photo JPG ou des mots-clés ont été appliqués dans PL3 pour les avoirs dans le fichier! Avec le prix du stockage sur Mac ce n’est pas du tout logique.

Pourquoi ne pas laisser la possibilité comme dans On1 ou Acdsee de les écrirent directement dans le fichier d’origine.
De plus sur une image comportent déjà des mots-clés, si j’en rajoute dans PL3 et que je l’exporte les nouveaux mots-clés ne sont pas ajoutés?

Merci de rajouter la possibilité d’ajouter un titre aux photos :slight_smile:


DxO vient de commencer a integrer la fonction de mot clé et quelque fonctionalité de gerance de fichier, qui n’est cependant pas complet mais c’est travail en progres, il n’y a pas beaucoup de programme avec complete fonctionalité et certain on commencer a les integrer depuis plus d’un an.

Having tagged my DNG files in a combination of Lightroom and another specific tagging tool, I can confirm that PhotoLab 3 can see the keywords.

Just added some keywords to a nef file. Opened that file in PL3. The keywords where visible. Added another keyword. Saved the image as jpg. Keywords including the new added keywords are visible in windows maps labeled as labels. But not visible in by example Irfanview. They only show the iptc keywords.
But when I delete a keyword in PL3 something strange happens. Opening that jpg again in PL3 shows me the keywords as expected. But looking in the windows file browser it’s showing the old iptc keywords.
It’s important not only to know what a program is doing but also what it is showing:frowning :frowning_face:. I mean any program.


Can I ask precisely how you added keywords? I have tried using ExifEditor to add keywords to the IPTC section and they don’t show up in DxO - even if I delete the database first.

For me (I don’t use Lightroom or any other software before DxO), it would seem the only way to get keywords to show is to create an XMP file manually.

Images taken with the D700 keywords where added with CaptureNx.
Since the D750 isn’t supported by CaptureNx I used Exiftools, till I shortly found out here that ViewNx still supported the D750. Nef files .
Are you sure ExifEditor writes keywords to a raw file? Is it Mac only?


Hi @Joanna

PhotoLab does not read IPTC keywords, only keywords in xmp section.

It does read iptc keywords. It doesn’t write them. See my former posts.
But there’s a special situation when both iptc and xmp keywords are used.

Thinking further, did you’ve also xmp keywords?